Windows 10 multiple display - windows are moved and resized on display power cycle

I have a Dell XPS 13 (2015) hooked up to an Asus 23" (MX239) monitor. They are connected via DisplayPort to HDMI cable. Both displays are set to 1920 x 1080px (their native resolution). The Dell XPS display is set to scale otherwise everything would be tiny. Also, for more detail, the Asus monitor is my primary (#1) display, and the Dell is display #2.

The big and super frustrating problem is that very frequently when the screens gets turned off by the Windows "Power & sleep" settings, all my windows on the Dell XPS 13 get moved over to the Asus monitor, as well windowed problems that are not full screen have their position on the display altered. Again, this happens when the displays are turned off by Windows, this is before the computer goes to sleep. When I touch a key or whatnot to wake the displays, they turn on and I see the above issue of moved and resized windows.

I am aware of this thread, which is still active, but it is titled Windows 7, and I noticed a Microsoft employee 4 years ago suggested starting a new thread. Since we are now through Windows 8, and on to Win 10, and this is still happening to people, let's start fresh here and get this fixed! Please. Please. Please.

I have also tried the reg edits some folks suggested in that old thread with no luck. And in my research it really does seem this issue is more common with folks not using HDMI to HDMI to connect their displays.

 

Question Info


Last updated June 15, 2019 Views 105,432 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Trevor,

Welcome to Microsoft Community. Your interest in Windows 10 is much appreciated. 

Method 1:

I would suggest you to update drivers for your Display card adapter from the Manufacturer’s website.

Method 2:

I would suggest you to create a new power plan and check the issue status. Creating a new power might help you to diagnose the issue.

For reference: Power plans: Frequently asked questions.

http://windows.microsoft.com/en-US/windows-8/power-plans-faq

Also refer:

http://windows.microsoft.com/en-in/windows-8/how-connect-multiple-monitors#1TC=t1

Keep us posted if you face any issues on windows in future. We will be glad to help you.

Thanks & Regards,
AS

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Annu!

Thanks for the follow up. Unfortunately I have the latest drivers available for an Intel 5500HD graphics card.

This is definitely an ongoing issue, I had it in Windows 8.1 on the same machine, and there are almost 100 replies in this thread, which is still active, regarding this issue, going back to Windows 7 and now into Windows 10 for people with all types of graphics cards and monitors.

Please see here:

http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/windows-7-movesresizes-windows-on-monitor-power/1653aafb-848b-464a-8c69-1a68fbd106aa?page=8&tm=1439182229675

Thanks!

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'd also like to provide more detail...I've spent A LOT of time testing this. What I've noticed:

- If I sleep from the Start Menu, then resume using laptop power button (but making sure the monitor itself is resumed first), the desktop layout is correct.

- If computer goes to sleep on timeout, then this issue occurs

- And I think I know why it only sometimes happens. If I have at least one open application (i.e. web browser) window maximized on my 2nd monitor, the one connected to my laptop via DisplayPort connectin, then when the computer goes to sleep this issue appear to NOT happen.

This is a bug with Windows clearly by the number of people reporting it, no way this is isolated to drivers or power plan settings.

42 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Annu -

I have a similar problem to Trevor, except with a single monitor. In my case, it's a Dell P2715Q with 3840x2160 resolution, connected via DisplayPort to a desktop using Intel HD Graphics 4600. When the computer puts the screen to sleep, the windows rearrange into the upper-left corner.

I've been suffering with the same problem since Windows 7. The suggestion in the thread Trevor links, to edit the settings for the simulated monitor under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration, did not fix the problem under Windows 7, and does not fix the problem under Windows 10.

Having researched the problem thoroughly, it's pretty clear what's happening. When Windows puts a monitor connected via DP to sleep, it then detects a device disconnect. In Trevor's case, this leaves his system thinking there's only one monitor. In my case, it means my system gets treated as a headless display with simulated video only. In either case, the windows rearrange.

This problem doesn't occur with monitors connected by some other kids of connectors, because Windows doesn't treat them as disconnected when they go to sleep. But do a web search, and you'll see a ton of people complaining about this problem.

The solution is to have Windows not treat the monitor as disconnected when the computer puts it to sleep. Is there any way to flag Windows to do that?

173 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had a very similar problem on a HP Spectre x360 laptop which has a native screen resolution of 1920x1080.  I am not using an external monitor.  After installing Windows 10, the default scaling was set to 150% which I reset to 100% (the other mode would not be useful to me).  Upon awaking from sleep windows were resized and moved to the top left (interestingly this did not occur for “settings” -- I didn’t do extensive checking of others native windows 10 routines).   

 

I tried the solution of modifying the registry but this did not work (see link referred to by Trevor Robertson in this thread).   One issue is that there was no “SIMULATED” entry under the “GraphicsDrivers\Configuration”  to change.  I did change the ActiveSize, PrimSurfSize and Stride values for one the configuration entries keys (MHS062…) that had 1024x768 for the sizes.  This seemed to help some.  Resizing did not occur for all sleep/wake scenarios but seemed to revolve mostly around activation sleep or waking with the lid.  (At this point I’m not sure what modes were working properly or not before I made this change.  I hadn’t fully realized the extent of the resizing problem when I started looking for a solution.)

 

I was about to give up but did one more search which turned up a solution seems to have worked (at least for my case).    This link:

 

http://www.tenforums.com/general-discussion/11890-intel-nuc-windows-resized-after-waking-sleep.html

 

points to a solution (option 2) which is here

 

http://www.tenforums.com/tutorials/5990-dpi-scaling-level-displays-change-windows-10-a.html#option2

 

The solution is to go to “Display” through the “Control Panel” and click on “set custom scaling level”.   I set the scaling level to “100%” (it was 150%) and this seems to have fixed the problem.   It is puzzling to me why this “scaling level” was (still) 150% since I has adjusted the scaling to 100% through the Windows 10 Settings by (adjusting the slider in System | Display).  Seems like a bug.

I'm not sure if editing the registry first was necessary as I left in the original changes I made (and now that it works I figure it best to leave well enough alone).

13 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I do have exactly the same problem since using Windows 10 (clean install). It did not appear to happen on Windows 7.

I currently have 2 monitors connected to a GTX 970 and one monitor to the onboard intel HD Graphics device.

Whenever I turn off the primary monitor, and the PC goes into sleep mode and back up, all windows I had opened on the other 2 monitors get rearranged on Monitor 1.

Monitor 1 is a ultra wide predator, all windows are also scaled to fit into the top left "normal" wide box. So Windows doesn't even remember the ultra wide resolution...

Seems this issue is around for a while, and update or confirmation that you guys can reproduce it, would be awesome.

And yes, I do use the latest nvidia drivers and everything. That's totally not the problem.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

For me with P2415Q and 4K UHD it turned out to be a known issue - lowering refresh rate to 30Hz fixed the problem. Issue affects UP3214Q, P2715Q and P2415Q and is described here:

http://www.dell.com/support/Article/us/en/19/SLN295708/EN

Registry clean for HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration\ was not helping and problem didn't manifest on lower res QHD U2515H.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

I think I may have a solution for this problem.  It appears Windows 10 keeps a history of all the monitors it encounters during its life time.  This includes the basic monitor support during the OS install.  So, if you enable "Show hidden devices" in the Device Manager you will see all the monitors that were connected to your system.

Start the Control Panel as Administrator:

1.  Start Control Panel --> Device Manager
2.  Select View --> Show hidden devices
3.  Expand Computer --> Monitors

When you expand the Monitors you will see your current monitor (highlighted) and all the disconnected monitors (greyed out).   You may see monitors with "non-PNP" and "PNP" listed as well.  I believe these are aliases to your current monitor (at a lower resolution) before Windows installed drivers for it.   

I uninstalled ALL the greyed out monitors.  Right-click on these monitors and select uninstall.  Keep only the highlighted monitor you are currently using.  

4.  Uninstall all greyed out monitors (even non-PNP and PNP monitors)
5.  Reboot your system.

After doing this my windows don't resize after my monitor goes to sleep.  You can quickly test this by temporarily setting your monitor sleep time to 1 minute.

Settings --> System --> Power & Sleep --> Screen [1 minute]

Cheers,

Stephen

379 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I will try your fix this afternoon.  

I see I do have my dual monitors there which show and the greyed out Generic Non-PnP Monitor.  If I uninstall the Generic Non-PnP is there something to worry about down the line if I change monitors or if these go out on me and I need to hook up another one?  will windows fail to show any monitor and I could end up screenless with no way to recover?

thanks

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have P2715Q monitor connected to NVIDIA GTX980 through DP connector together with another monitor (Apple 27 LED Cinema Monitor) connected via another DP connector and was experiencing exactly the same issue - after waking up the monitors from sleep, all windows were moved to the Apple monitor and resized due to different scaling ratios. Lowering the refresh rate on P2715Q to 30Hz helped resolve the issue, at least so far.

However, this is pretty lame as it affects the "motion smoothness" and generally lowers the quality of the display. It would be great to have a fix that wouldn't require lowering the refresh rate. It seems like this is related to the fact that to use this monitor with 60Hz, the DP port must be in DP 1.2 mode. Somehow either NVIDIA driver or Windows itself (or a combination of both) have issues with this when waking up the monitor from sleep. I saw this issue reported by other folks using a different graphics card (like integrated Intel for example) so I suspect this is a Windows issue rather than a driver issue.

It is not a HW issue, because this exact setup works great when running Mac OS X. Resume from sleep causes no issues there.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.