回滚至1809版本后所有第三方应用打开时显示参数错误

我从1903回滚至1809之后出现打开第三方UWP应用时显示参数错误的问题,在我电脑上出现问题的应用有①英特尔显卡控制中心、②Snipaste、③Ditto、④Quicklook,这些应用是我所有的开机自启动的第三方UWP应用,同时在关机之前尝试再次打开这些应用都会出现参数错误的问题,删除应用并从Windows商店重新下载应用也不能解决问题。(Quicklook的win32版本能正常打开)

在这之后我将 WindowsApps 文件夹的所有者改为了 Everyone,在关机之前解决了问题,但重新启动之后问题又重新发生了。

唯一能使这些应用自启动并不报参数错误的方法是开机之后停留在登陆界面,等待应用自启动完成之后再登陆,这样便不会出现参数错误的问题。

请问我要怎样设置才能让我在正常开机流程之后不会出现UWP应用自启动与打开之后不会出现参数错误的问题?

|
您好,
了解到您的问题,请您先不要着急。

您可以使用管理员powershell来执行以下命令

Get-AppxPackage -AllUsers| Foreach{Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

希望这可以帮助到您。
如果有任何问题,请不要客气!
愿与您共同交流、成长、进步!

此回复是否有帮助?

抱歉,没能帮到你。

太棒了!感谢你的反馈。

你对此回复的满意度如何?

感谢你的反馈,它能帮助我们改进网站。

你对此回复的满意度如何?

感谢你的反馈。

您好
您可以Win+R, 运行一下WSReset.exe
同时,您也可以打开设置,应用,应用和功能,在已安装的列表里找到Microsoft store,点击后选择高级选项,有个重置
同时,可以的话麻烦您也重置一下应用安装程序
祝好
Reference:
https://answers.microsoft.com/zh-hans/windows/f...

此回复是否有帮助?

抱歉,没能帮到你。

太棒了!感谢你的反馈。

你对此回复的满意度如何?

感谢你的反馈,它能帮助我们改进网站。

你对此回复的满意度如何?

感谢你的反馈。

您好,
了解到您的问题,请您先不要着急。

您可以使用管理员powershell来执行以下命令

Get-AppxPackage -AllUsers| Foreach{Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

希望这可以帮助到您。

您好,您提供的方案不能解决我的问题,请问还有其他的解决方法吗?

此回复是否有帮助?

抱歉,没能帮到你。

太棒了!感谢你的反馈。

你对此回复的满意度如何?

感谢你的反馈,它能帮助我们改进网站。

你对此回复的满意度如何?

感谢你的反馈。

您好
您可以Win+R, 运行一下WSReset.exe
同时,您也可以打开设置,应用,应用和功能,在已安装的列表里找到Microsoft store,点击后选择高级选项,有个重置
同时,可以的话麻烦您也重置一下应用安装程序
祝好
Reference:
https://answers.microsoft.com/zh-hans/windows/f...
您好,您提供的方案不能解决我的问题,请问还有其他的解决方法吗?

此回复是否有帮助?

抱歉,没能帮到你。

太棒了!感谢你的反馈。

你对此回复的满意度如何?

感谢你的反馈,它能帮助我们改进网站。

你对此回复的满意度如何?

感谢你的反馈。

 
 

问题信息


上次更新时间 2021/02/01 126 次浏览 适用于: