Por que o Windows não consegue transferir arquivos com nomes muito longos?

O pior de tudo é que não consigo excluir uma pasta com muitos arquivos com nomes longos. Tentei renomeá-los, mas como tentei apagá-los com outros softwares, não há mais esta opção no menu de contexto ou shift+del.

Existe alguma maneira de evitar que o Windows não tenha problemas com arquivos com nomes muito grandes, pois renomeá-los um por um seria um passo atrás em termos de praticidade.

Muitos programas nomeiam arquivos automaticamente ao salvá-los, facilitando muito, mas esta situação dos nomes longos acaba atrapalhando.

Obrigado.

 

Informações sobre a pergunta


Última atualização junho 18, 2019 Exibições 70.243 Aplicável a:
Resposta
Resposta
Sugiro que utilizes um software de terceiros como por exemplo o DevinvFile (http://www.purgeie.com/delinv/index.htm) para eliminares esse tipo de ficheiros/pastas. Não sei se vais conseguir eliminar os ficheiros que pretendes com a versão demonstração mas posso dizer-te que na versão completa o vais conseguir de certeza.
Nota:
Podem existir outros aplicativos tão bons ou melhores que este e gratuitos que te permitem atingir o mesmo objectivo, por isso sugiro que efectues uma pesquisa na Internet por este tipo de software.

--

Jorge Moura [MVP]
 
 
 
"Heitor Braga" escreveu na mensagem news:c8de112e-b3f6-45e3-83e3-337b171f58b8...

Muito obrigado Jorge.

Agora compreendi o "esquema".

O problema era exatamente este. Eu tinha muitos arquivos com nomes grandes e ainda em muitas subpastas. O total ia estourar o limite mesmo.

Aproveitando, gostaria de saber se você poderia me ajudar neste outro problema:

Estes dias atrás eu criei uma pasta com várias subpastas e arquivos longos. Não consegui apagá-la da maneira convencional e tentei outros programas e não deu mesmo assim. Não sei o que ocorreu, mas não consigo mas renomear ou mover esta pasta e os arquivos nela contidos. Se tornaram "indeletáveis".

Há um jeito alternativo de deletar arquivos no Windows?

Masi uma vez obrigado. Aprendi muito.

---
Jorge Moura [MVP]
http://ojmoura.wordpress.com/
http://dicaspowershell.wordpress.com/

Isso resolveu o problema?

Isso não ajudou.

Ótimo! Obrigado por marcar essa opção como resposta.

Qual o seu grau de satisfação com esta resposta?

Obrigado por seus comentários. Isso nos ajuda a melhorar o site.

Qual o seu grau de satisfação com esta resposta?

Obrigado por seus comentários.

Resposta
Resposta
Por omissão o explorador do Windows (bem como o copy e o xcopy) só conseguem efectuar operações de cópia com nomes ou caminhos que não excedam os 256 caracteres (este valor foi revisto no Windows Vista para 260). Se tiveres um documento que tenha um nome longo e cujo caminho seja também algo longo mas não ultrapasse no seu conjunto os 256 caracteres (por exemplo 230) podes usar sem problema o explorador do Windows para fazer essa operações, no entanto se criares por exemplo uma pasta com um nome muito longo (por exemplo 200 caracteres) e se quiseres copiar o conteúdo anterior para essa pasta o total do caminho e nome do ficheiro vão ultrapassar os 256 caracteres e vai ocorrer o erro que descreves.
Existem diversas formas de ultrapassar esta questão:
1 - Podes mapear partilhar a pasta destino para um nome curto e efectuares a operação de copia. Exemplo: partilha a pasta "FicheirosAqui" que se encontra em "c:\Document and Setting\Nome do Utilizador Muito Longo\Ambiente de Trabalho\Nome de uma pasta muito longo\Dentro de outra pasta com um nome muito longo\FicheiroAqui" para o nome "A". Efectuas um mapeamento de um drive (por exemplo X: ) para esta partilha e em vez de teres aquele nome longo passas a poder aceder lá apenas escrevendo X:\A
2 - Utilizar o robocopy. Este utilitário é distribuído com o Windows e não tem a limitação dos caracteres. Em teoria podes copiar caminhos até 32000 caracteres. Para mais informações sobre este utilitário de cópia escreve na linha de comandos "robocopy /?"

--

Jorge Moura [MVP]
 
 
 
"Heitor Braga" escreveu na mensagem news:ec196341-3dd2-498d-92c2-9f10ce1e4e22...

Olá Jorge.

Fico agradecido pelas informações, mas realizo as transferências para locais com sistema de arquivos ntfs (como o do Windows), pois prefiro este para pen drives, etc.

E este problema dos nomes muito longos também ocorre em transferências dentro do próprio local onde está o Windows. Do Desktop para Documentos, por exemplo.

 

---
Jorge Moura [MVP]
http://ojmoura.wordpress.com/
http://dicaspowershell.wordpress.com/

18 pessoas foram ajudadas por esta resposta

·

Isso resolveu o problema?

Isso não ajudou.

Ótimo! Obrigado por marcar essa opção como resposta.

Qual o seu grau de satisfação com esta resposta?

Obrigado por seus comentários. Isso nos ajuda a melhorar o site.

Qual o seu grau de satisfação com esta resposta?

Obrigado por seus comentários.