Windows7SP1導入後のVirtualPC統合コンポーネントの更新(再インストール)ができない

Win7Pro(64bit)にてXPModeを使用しております。

 

SP1インストールは問題なく終了。XPModeを立ち上げたところ、VirtualPC統合コンポーネントの更新という表示がされました。

早速セットアップを行ったところ、失敗(別のバージョンがインストールされている云々)しました。

フォルダ内の.msiから直接実行しても同じ状況で更新できませんでした。

 

検索を行い解決策を探り、次のことがわかりました。

1 ユーザーパスワードの設定がないと更新できない

2 すでにインストール済みの統合コンポーネントを削除しないとインストールできない

 

パスワードについては最初から設定してあり問題ないので、コントロールパネルのプログラムの追加と削除からインストール

されていた「統合コンポーネント」を削除・再起動して再び更新セットアップを実行しました。

しかし、インストールの最終段階(「製品を登録しています」表示の後あたり)で、「操作を元に戻しています」と表示され、

インストールができず、再度実行を求められます。

メニューの「ツール」→「統合コンポーネントのインストール」の操作も行いましたが一瞬砂時計が出て、その後何も起こらない

状況です。

 

バックアップからシステムをSP1適用前に戻し、SP1を除くWindowsUpDate(表示されたカスタムインストールもすべて含む)

を完全に行った後にSP1を適用し、その後WindowsUpDateを行う必要がないことを確認したのちに、あらためてセットアップを

行いましたがやはり失敗(別のバージョンがインストールされている云々)しました。

「統合コンポーネント」を削除し、再起動して再び更新セットアップを実行しても「操作を元に戻しています」となり、結局最初と同じでした。

 

http://www.microsoft.com/japan/windows/virtual-pc/download.aspx

へ行き、WindowsXPModeUpdateファイルをダウンロードし(Windows6.1-KB977206-x64.msu)、Windows7上で実行しましたが、

「この更新プログラムはお使いのコンピューターには適用できません」でした。

 

検索を行っても他にめぼしい情報はなく、詰まってしまいました。今は、SP1を適用し、統合コンポーネントの更新は行わずに

XPModeを使用しております。

 

VirtualPC統合コンポーネントの更新/再インストール障害の原因と解決法をご教授下さい。よろしくお願いいたします。

 

質問情報


最終更新日 2018年11月12日 表示 25,438 適用先:
回答
回答

松下 様
surgeon_893 様

 

いろいろお調べいただき、大変恐縮です。

解決したかもしれません(確認の仕方がわからないので)。

 

technetの本家(?)に何か情報はないかと思って検索しておりました。

やはり同様の現象に悩んでいる方がいるようで、

http://social.technet.microsoft.com/Forums/pl-PL/w7itprovirt/thread/12d97708-a439-43fd-b556-1f646aee8068

いろいろ探していると、次のページがヒットしました。

http://social.technet.microsoft.com/Forums/en-IE/w7itprovirt/thread/a6069f5b-2261-4c15-b625-610799f1badb

何やらXPMode上のXPのC:\Windows\System32の中のwdf01000.sys

というファイルをwdf01000.sys.oldに書き換えてインストール操作をしろ、という記述が。

 

で、早速それを以下の手順で行ってみました。

 

1 XPMode立ち上げ

2 インストール推奨表示をキャンセル

3 ツールメニューから統合機能を無効にする

4 コントロールパネルのプログラムの追加と削除から統合コンポーネントをアンインストール

5 C:\Windows\System32の中のwdf01000.sysというファイルをwdf01000.sys.oldにリネーム

6 XPModeを再起動

7 Dドライブのsetup.exeを起動

 

したところ、インストールに成功した模様で、再起動を促され、再起動後メニューから統合機能を有効にし、

全画面表示にもなり、XPのデスクトップ上のファイルを1つコピーしたところ、Windows7のデスクトップに

貼り付けることができました。

 

なぜ、wdf01000.sysをリネームするとインストールに成功するのか理由はさっぱりわかりません。

また、本当に統合コンポーネントが本当に新しいバージョンに置き換わったのか、どこを確認すればその証拠を

(バージョンNoとか)みられるのかわからないので、今一つ実感というか達成感というかがありません。

とりあえず、インストールという行為がエラーを吐くことなく無事終了した、ということをご報告申し上げます。

 

インストールドライブ(?)であったDドライブは、マイコンピュータから消えています。

 

ところで、件のファイルがwdf01000.sys.oldとリネームされたままなんですが、削除しちゃっていいのでしょうか…?

 

この回答で問題は解決しましたか?

役に立ちませんでした。

回答としてマークしていただきありがとうございます。

この返信の満足度をお教えください。

フィードバックをお送りいただきありがとうございます。今後のサイト改善に役立てて参ります。

この回答の満足度をお教えください。

フィードバックをお送りいただきありがとうございます。