パッケージ版Windows 10 Home 64bitをインストールしたところ、NASが見えなくなった

デスクトップPCにパッケージ版Windows10 Home 64bitをインストールしたところ、ネットワークにNASが見えなくなり困っています。エクスプローラの左側タブのネットワークに表示されるのは、このPCだけです。2台のNASは見あたりません。workgroup名は同じに揃えてあります。

 NASに対しては、ipアドレス/hostnameのいずれでもpingは通ります。このPCは別ドライブからWindows7 Proが起動できるのですが、こちらをブートすればネットワークにNASが表示され、ネットワークドライブも問題なく使えます。そのため、ハブ、LANケーブルに問題があるとは思えません。

 また、このPCとは別にノートPC(Windows8からWindows10 Proにアップグレード済み)があるのですが、こちらからもNASは見え、ネットワークドライブも使えます。なので、NAS側に問題はなさそうに思えます。

 問題のPCから、NASに対し、\\nas名でアクセスすると共有フォルダを見ることができます。しかし、username/passwordを入力しアクセスしようとすると、「\\nas名\publicにアクセスできません。このネットワークリソースを利用するアクセス許可がない可能性があります。アクセス許可があるかどうかこのサーバーの管理者に問い合わせてください。指定されたログオンセッションは存在しません。そのセッションは既に終了している可能性があります。」とエラーメッセージが出てアクセス拒否されます。ユーザアカウントで資格情報を追加しても状況は変わりません。

 このPCからノートPC(Windows 10 Pro)はネットワーク上に見えます。しかし、username/passwordを入力してアクセスしようとすると、nasの場合と同じエラーメッセージが出てアクセスできません。逆にノートPC(Windows 10 Pro)からこのPCを見た場合、ネットワーク上に見えますし、c:\usersにアクセスすることができます。

 システムのプロパティでコンピュータ名タブを表示させると、ネットワークIDがグレーアウトしており押すことができません。イーサネットアダプタの「インターネットプロトコル バージョン4(TCP/IPv4)」のWINSを「NetBIOS over TCP/IPを有効にする」を選んでも状況は変わりません。nbtstatでマスターブラウザを調べてみるとこのPCにあったりnasにあったり色々です。ただ、nbtstatでnasを調べると、"MAC アドレス = 00-00-00-00-00-00"となっており、MACアドレスが取得できていません。

 このPCにはOSとアプリケーションしか入れておらず、データ類はすべてNAS上に置いてあるので非常に困っています。どなたかお分かりになる方がおいででしたら、よろしく御教示お願いいたします。

NASは、どの製品でしょうか?

NASの情報を提示してもらうと、情報が集まるかと思います。

この返信が役に立ちましたか?

役に立ちませんでした。

素晴らしい!フィードバックをありがとうございました。

この返信の満足度をお教えください。

フィードバックをお送りいただきありがとうございます。今後のサイト改善に役立てて参ります。

この返信の満足度をお教えください。

フィードバックをお送りいただきありがとうございます。

高橋様、コメントありがとうございました。

NASはNetgear製ReadyNAS Ultra2 Plus、ReadyNAS Duo v2の2台です。

OSはDebian GNU Linuxと思われます。

相変わらず、ネットワークにNASは現れませんが、とりあえず、net useコマンドでネットワークドライブに割り当てることができました。

構文は下記のとおりです。(s:\に割り当てる場合)

c:\net use s: \\hostname\sharename /user:username password /persistent:yes

"persistent:yes"オプションを付けているにもかかわらず、リブート/シャットダウンするたびにネットワークドライブ切断状態となります。

そのたびに、コマンドプロンプト開いてポチポチ打ち込まなければNASが利用できません。

根本的解決になっていませんが、一応使えるので、しばらくこの方法で運用しようかと思っています。

この返信が役に立ちましたか?

役に立ちませんでした。

素晴らしい!フィードバックをありがとうございました。

この返信の満足度をお教えください。

フィードバックをお送りいただきありがとうございます。今後のサイト改善に役立てて参ります。

この返信の満足度をお教えください。

フィードバックをお送りいただきありがとうございます。

他のNASでも、同様の事象がでている方がいます。

簡単に調べたところ、プレビュー版からReadyNAS利用者でも出ているようで、Windows10のSMBのバージョンが変わっているのではとやり取りしているのを散見します。

プレビュー版時では、Windows10のSMBをSMB1.5にすると出来たとあります。

(また、パスワードをPINコードにしているとログイン出来ないなど)

https://social.technet.microsoft.com/Forums/en-US/bcaf3172-83bc-4230-860b-f6887bf65356/accessing-nas-not-working-in-windows-10-technical-preview?forum=WinPreview2014General

これが、現在のver.でも引き続き同じ状態になるのかは分かりません。

この返信が役に立ちましたか?

役に立ちませんでした。

素晴らしい!フィードバックをありがとうございました。

この返信の満足度をお教えください。

フィードバックをお送りいただきありがとうございます。今後のサイト改善に役立てて参ります。

この返信の満足度をお教えください。

フィードバックをお送りいただきありがとうございます。

高橋さま、ありがとうございます。

SMBの件、調べてみようと思います。

Windows8からWindows10にアップグレードしたノートPCでは問題なくアクセスできるので、Windows10クリーンインストールの問題かもしれませんね。

このノートPCではPINでサインインしていますが、Windows資格情報にusername/passwordを明示的に記入しているためか問題なくNASに接続できます。

同じような事例に当たった方の情報も併せて調べてみたいと思います。

この返信が役に立ちましたか?

役に立ちませんでした。

素晴らしい!フィードバックをありがとうございました。

この返信の満足度をお教えください。

フィードバックをお送りいただきありがとうございます。今後のサイト改善に役立てて参ります。

この返信の満足度をお教えください。

フィードバックをお送りいただきありがとうございます。

 
 

質問情報


最終更新日 2021年4月09日 表示 3,164 適用先: