スリープ/自動モニタOFFからの復帰時画面が表示されない

インテルHDグラフィックの問題だと思われるのですが、解決方法がわかる方がいらっしゃればご教示ください。

[症状概要]
スリープもしくは自動モニタOFFから復帰する場合に、インテルHDグラフィック3000に接続されているモニタに画像が表示されません。
100%の確率で発生するわけではなく、感覚的には30%程度の確率で発生します。つまり正常動作する場合もあります。
対処療法としてこの症状から復帰させる方法は発見しましたが、毎度この操作を行わなければならないのは煩わしいです。

[対処療法]
Intel(R) HD Graphic Familyのプロパティで「ドライバ」タブから一度このデバイスを無効にして、それから再度有効にするとモニタ表示は復帰します。

[PC環境]
M/B: ASRock Z68M/USB3 (Z68チップセット)
CPU: Core-i7 2600K
Video: Intel HD3000(Core-i7 2600K内蔵) + ATI RADEON HD 6570
モニタ: それぞれのVideoカードにHDMI接続で1台ずつ。計2台。 

[症状詳細]
本PCには、Coire-7(2600K)内蔵のHD3000の他に、ATI RADEON HD R6570も搭載しているのですが、R6570に接続しているモニタには正常に画像が表示されます。
この症状がでている状態でも、システムは2つのビデオカードとそれぞれに接続されているモニタを認識しています。(「画面の解像度」にて確認できます。)
そして、表示されていないモニタ上にもアプリケーションのウィンドウは表示されているようで、動作中のウィンドウの一部が見えなくなっていたりします。
タスクバーから操作して、この見えていないウィンドウを表示されているモニタ側に移動することができました。

対処療法でこのデバイスを無効にすると、表示されていないモニタ側に配置されていたウィンドウは表示されている(R6570側に接続されている)モニタ側に自動的に移動してきますので、この症状が発生している状態でもシステムとしてはハード的にもソフト的にもデバイスもモニタも認識していて、正常に動作しているつもりになっていると判断されます。

R6570側に接続されているモニタは常に正常に復帰します。2つのビデオカードに接続されているモニタを交換すると、いずれもHD3000側に接続したモニタに障害が現れます。
スリープ/自動モニタOFFから以外にも、電源OFFの状態からモニタの電源を入れた場合にも同様の症状は発生します。

HDグラフィックがモニタOFFから復帰する際にハード的にエラーが発生するなどの問題が生じているのではないかと推測しています。
現在ドライバは最新(8.15.10.2509 2011/08/31)を使用しておりますが、ドライバ更新前はおそらく100%の確率でこの問題が発生しておりまして、ドライバで制御可能な問題であり、インテルにドライバを更新してもらわないと直らない問題なのかもしれません。

おそらく、R6570側に2台のモニタを接続すれば問題は回避できるものと思いますが、モニタを3台接続する予定であり、その前の実験としてそれぞれのビデオデバイスにモニタを接続しております。

HDグラフィックスとビデオカードの併用は、第2世代Core + Z68チップセットからの機能のようですので、同様の環境をご利用の方は少ないとは思いますが、
ご助言をいただければ幸いです。
|
回答
回答

私も同じような症状で困っていました。

OS:  Windows 7 SP1[64ビット]

CPU インテル Core i3 2125

マザーボード ASUSTeK P8H67-I REV 3.0

グラフィックボード 無し

モニター IOデータ LCD-MF221XBR

DVIケーブルで接続した時にパソコンの起動、再起動、スリープからの復帰時にモニターが映らなくなる事がよくありました。

一週間ほどパソコンとD-Subケーブルで接続してみた時は、この症状は出ませんでした。

モニターの電源を入れてからPCの電源を入れる方が症状が出にくいとも感じていました。

 

モニターの初期不良を疑ってIOデータに問い合わせてみたところ、過去にATIのグラフィックドライバで、同じ様な症状が出たことがあるそうで、グラフィックドライバのバージョンを変える事で改善したそうです。

改善したドライバのバージョンは人それぞれ違っていたようです。

 

1週間前にインテル HD Graphics 3000 を「バージョン 8.15.10.2653」にアップデートしてからは、画面が映らないという症状は今のところ出ていません。

参考になればいいのですが。

1 人がこの回答を役に立ったと思いました。

·

この回答が役に立ちましたか?

役に立ちませんでした。

素晴らしい!フィードバックをありがとうございました。

この回答にどの程度満足ですか?

フィードバックをありがとうございました。おかげで、サイトの改善に役立ちます。

この回答にどの程度満足ですか?

フィードバックをありがとうございました。

回答
回答

私も同じような現象に遭遇しました。CPUはCore i5-2400でチップセットはH67です。(ASRock  H67M-ITX/HT)

PCの電源を入れる前にモニタを電源オンにしておかないと映らない。またスタンバイかスリープかモニタ省電力モード状態だと思われる状態からキーボードを操作してもPC本体はパワーLEDグリーンなのにモニタは映らないなどの現象です。

 

結局それはモニタの問題でした。(うちはビデオカードを装着せずHD2000しか使っていなかったので切り分けが出来なかったですが) そのモニタを他のモニタにしてみたらちゃんと映りました。

 

ただ改善方法としてはその該当モニタをアナログ接続にしたら問題無い事を発見しました。うちはDVIにしてたのでそれが原因のようでした。なのでもしHD3000のアナログ接続が可能であればそうしてみると良いかもしれません。

 

ASRock(の日本代理店)に質問したらモニタかマザーの問題であってマザーボードの仕様ではないと回答を得てますが、モニタの方の保証期間は切れていたのでモニタメーカーには何も連絡せずアナログ接続で使用しています。

参考になれば。

 

何かする時は重要データのバックアップをしてください。

すもも

この回答が役に立ちましたか?

役に立ちませんでした。

素晴らしい!フィードバックをありがとうございました。

この回答にどの程度満足ですか?

フィードバックをありがとうございました。おかげで、サイトの改善に役立ちます。

この回答にどの程度満足ですか?

フィードバックをありがとうございました。

 
 

質問情報


2021年6月10日最終更新日 表示数 37,712 適用先: