Trovare valori in una tabella

Prendiamo la classica tabella in 2 "variabili", devo ricercare un numero all'interno di essa, dati due valori: uno sulla colonna a sinistra, e uno sulla riga superiore...riesco a fare solo cerca verticale, ma a questo punto l'indice (che corrisponde al valore nella prima riga orizzontale) glielo devo fornire io...in pratica dovrei incrociare il cerca verticale con il cerca orizzontale...come si fa?
 

Informazioni domanda


Ultimo aggiornamento giugno 21, 2018 Visualizzazioni 2.749 Si applica a:
Risposta
Prendiamo la classica tabella in 2 "variabili", devo ricercare un numero all'interno di essa, dati due valori: uno sulla colonna a sinistra, e uno sulla riga superiore...riesco a fare solo cerca verticale, ma a questo punto l'indice (che corrisponde al valore nella prima riga orizzontale) glielo devo fornire io...in pratica dovrei incrociare il cerca verticale con il cerca orizzontale...come si fa?


Intestazioni tabella da A2 a A7 e da B1 a E1

I dati della tua tabella da B2 a E7.

Nella cella dove vuoi il risultato:  =INDICE(B2:E7;CONFRONTA(H1;A2:A7;0);CONFRONTA(H2;B1:E1;0))

In H1 uno dei valori di colonna A.

In H2 uno dei valori della riga 1.

 

Qui puoi scaricare il file d'esempio duevariabili.xls:

https://skydrive.live.com/#cid=0361684D94BB851A&id=361684D94BB851A%21169

http://www.maurogsc.eu/esempiforum12/duevariabili.zip

--
Mauro Gamberini
Microsoft© MVP (Excel)
http://www.maurogsc.eu

La risposta è risultata utile a 2 persone

·

Il problema è stato risolto?

Siamo spiacenti che questo non sia stato d'aiuto.

Fantastico! Grazie per aver scelto questa risposta.

Sei soddisfatto di questa risposta?

Grazie per il tuo commento, ci aiuta a migliorare il sito.

Sei soddisfatto di questa risposta?

Grazie per il tuo commento.

Risposta
Perfetto, funziona. ma se ora al posto dei valori esatti volessi trovare numeri vicini (sulla prima riga e colonna), e quindi metto -1 o +1 al posto del valore 0, come mai non funziona? mi segnala N/D...


Capito poco.

Leggi comunque bene cosa fa il parametro Corrisp nella funzione CONFRONTA(). Se non è settato a 0, le matrici devono essere ordinate, in ordine crescente o decrescente a seconda del caso.

Se ho capito quello che vuoi(dubito), il +1/-1 va messo *al di fuori* delle parentesi del CONFRONTA(), ad esempio:

=INDICE(B2:E7;CONFRONTA(H1;A2:A7;0);CONFRONTA(H2;B1:E1;0)+1)

--
Mauro Gamberini
Microsoft© MVP (Excel)
http://www.maurogsc.eu

La risposta è risultata utile a 1 persona

·

Il problema è stato risolto?

Siamo spiacenti che questo non sia stato d'aiuto.

Fantastico! Grazie per aver scelto questa risposta.

Sei soddisfatto di questa risposta?

Grazie per il tuo commento, ci aiuta a migliorare il sito.

Sei soddisfatto di questa risposta?

Grazie per il tuo commento.