menu a tendina excel per calcolo

buongiorno a tutti.

 

dovrei creare una formula per il calcolo delle spese di roaming.

 

in un foglio 1 ho un elenco dove nella colonna 1 ho il paese, mentre nella colonna 2 ho il costo al mega in quel paese.

 

vorrei creare in un altro foglio una formula dove nella prima cella digito manualmente il valore dei mb che consumo, nella seconda cella ho un menu a tendina dove vengono visualizzati tutti i paesi elencati nella colonna 1 del foglio 1 e nella cella 3 automaticamente viene riportato il costo al mega della colonna 2 del foglio 1. nella cella 4 poi farò la moltiplicazione dei mega inseriti per il costo al mega riferito a quel paese in modo da ottenere il costo totale.

 

sono riuscito a creare il menu a tendina usando la funzione convalida, ma non so come fare in modo che la selezione del paese porti con sé anche il costo associato. Come posso fare?

 

Spero di essere stato chiaro

 

grazie

 

Davide

 

Informazioni domanda


Ultimo aggiornamento febbraio 27, 2018 Visualizzazioni 854 Si applica a:
Risposta

buongiorno a tutti.

 

dovrei creare una formula per il calcolo delle spese di roaming.

 

in un foglio 1 ho un elenco dove nella colonna 1 ho il paese, mentre nella colonna 2 ho il costo al mega in quel paese.

 

vorrei creare in un altro foglio una formula dove nella prima cella digito manualmente il valore dei mb che consumo, nella seconda cella ho un menu a tendina dove vengono visualizzati tutti i paesi elencati nella colonna 1 del foglio 1 e nella cella 3 automaticamente viene riportato il costo al mega della colonna 2 del foglio 1. nella cella 4 poi farò la moltiplicazione dei mega inseriti per il costo al mega riferito a quel paese in modo da ottenere il costo totale.

 

sono riuscito a creare il menu a tendina usando la funzione convalida, ma non so come fare in modo che la selezione del paese porti con sé anche il costo associato. Come posso fare?

 

Spero di essere stato chiaro

 

grazie

 

Davide

Ciao Davide,
supponiamo che la cella B1 contenga il paese da convalida dati, Foglio1!$A$1:$B$50 la tabella paese, costo mb, usa questa formula:

=SE.ERRORE(CERCA.VERT(B1;Foglio1!$A$1:$B$50;2;FALSO);0)

adatta gli intervalli alle tue esigenze.

Ciao,
Andrea.
Andrea

Il problema è stato risolto?

Siamo spiacenti che questo non sia stato d'aiuto.

Fantastico! Grazie per aver scelto questa risposta.

Sei soddisfatto di questa risposta?

Grazie per il tuo commento, ci aiuta a migliorare il sito.

Sei soddisfatto di questa risposta?

Grazie per il tuo commento.