filtro condizionato

in excel 2007 da A1 a A100 riporto una numerazione non ordinata, es. 20 - 32 - 100 - 4 - ....... (e così sino a completare i 100 numeri).

da C1 a C .... vorreri inserire una formula che mi permetta di riportare solo i numeri che iniziano che contengono il 5 o il 7 o entrambi. Nell'applicare la formula a C2, C3, ecc. non devono essere lasciate caselle vuote.

grazie, Michele

 

Informazioni domanda


Ultimo aggiornamento febbraio 27, 2018 Visualizzazioni 166 Si applica a:
Risposta

Mi ero dimenticato il 7 ... sempre matriciale:

=INDICE(lista;PICCOLO(SE(LUNGHEZZA(SOSTITUISCI(SOSTITUISCI(lista;"5";"");"7";""))<>LUNGHEZZA(lista);RIF.RIGA(lista)-1;"");RIGHE(G$1:G1)))

Andrea.

Andrea

Il problema è stato risolto?

Siamo spiacenti che questo non sia stato d'aiuto.

Fantastico! Grazie per aver scelto questa risposta.

Sei soddisfatto di questa risposta?

Grazie per il tuo commento, ci aiuta a migliorare il sito.

Sei soddisfatto di questa risposta?

Grazie per il tuo commento.

Risposta

grazie, è quello che cercavo. mi piacerebbe che la formula avesse la possibilità di selezionari i numeri che contengono il 5 o il 7. (rileggendo la mia richiesta mi sono accorto dei tanti errori commessi nell'esporre il quesito)

Le formule NON SELEZIONANO nulla. Se quello che vuoi è che, oltre ad avere in colonna C i dati delle celle di colonna A che contengono 5 e 7, le celle in colonna A che contengono un 5 o un 7 siano selezionate, devi usare una macro. Questa una delle soluzioni possibili:

Public Sub m()

    Dim sh As Worksheet
    Dim lC As Long
    Dim lng As Long
    Dim rng As Range
    
    Set sh = ThisWorkbook.Worksheets("Foglio1")
    lC = 1
    
    With sh
        For lng = 1 To 100
           If InStr(CStr(.Cells(lng, 1).Value), "5") Or _
                InStr(CStr(.Cells(lng, 1).Value), "7") Then
                If rng Is Nothing Then
                    Set rng = .Cells(lng, 1)
                Else
                    Set rng = Union(rng, .Cells(lng, 1))
                End If
                .Cells(lC, 3).Value = .Cells(lng, 1).Value
                lC = lC + 1
           End If
        Next
    End With
    
    rng.Select
    
    Set rng = Nothing
    Set sh = Nothing
    
End Sub

Modifica i riferimenti con i tuoi. Il file va copia/incollato in un modulo standard. Se non hai mai utilizzato in vb di Excel, vedi qui:

Qui trovi il file utilizzato per l'esempio:

--
Mauro Gamberini
Microsoft© MVP (Excel)
http://www.maurogsc.eu

Il problema è stato risolto?

Siamo spiacenti che questo non sia stato d'aiuto.

Fantastico! Grazie per aver scelto questa risposta.

Sei soddisfatto di questa risposta?

Grazie per il tuo commento, ci aiuta a migliorare il sito.

Sei soddisfatto di questa risposta?

Grazie per il tuo commento.