Problème de date dans une publipostage

Bonjour,

Lors d'un publipostage (Word 2010 - Excel 2010), la date ne s'inscrit pas correctement.

Mon champ de fusion a le format "{ MERGEFIELD Date1 \@ dd/MM/yyyy }. Lorsque j'affiche résultat, je n'ai pas la date 18/09/2015 mais le chiffre 42265.

Quelqu'un a-t-il une solution?

Merci

Anelyse

|

Bonsoir Anelyse

Avec des guillemets sur le format date après le commutateur { MERGEFIELD Date1 \@ "dd/MM/yyyy" }, c'est mieux ?

Argitxu

6 personnes ont trouvé cette réponse utile

·

Cette réponse vous a-t-elle été utile ?

Nous sommes désolés de ne pas pouvoir vous aider.

Super ! Merci de vos commentaires.

Êtes-vous satisfait de cette réponse ?

Nous vous remercions de vos commentaires, qui nous aideront à améliorer le site.

Êtes-vous satisfait de cette réponse ?

Merci de vos commentaires

Bonjour,

Le fait de mettre des guillemets ne change rien.

Mais, oh miracle, sans rien changer, cela fonctionne pour l'instant!

Merci pour la réponse

Anelyse

Cette réponse vous a-t-elle été utile ?

Nous sommes désolés de ne pas pouvoir vous aider.

Super ! Merci de vos commentaires.

Êtes-vous satisfait de cette réponse ?

Nous vous remercions de vos commentaires, qui nous aideront à améliorer le site.

Êtes-vous satisfait de cette réponse ?

Merci de vos commentaires

Bonjour,

Le miracle n'a pas duré très longtemps. Je me retrouve avec le même problème.

Quelqu'un a-t-il une solution?

Merci

Anelyse

Cette réponse vous a-t-elle été utile ?

Nous sommes désolés de ne pas pouvoir vous aider.

Super ! Merci de vos commentaires.

Êtes-vous satisfait de cette réponse ?

Nous vous remercions de vos commentaires, qui nous aideront à améliorer le site.

Êtes-vous satisfait de cette réponse ?

Merci de vos commentaires

Rebonjour,

Je me rends compte que le nombre obtenu lors de la fusion correspond dans le fichier Excel à la transformation de la date.

C'est-à-dire que si, dans Excel, je remplace le format Date par le format Nombre c'est ce nombre que j'obtiens.

Que faire?

Merci

Anelyse

Cette réponse vous a-t-elle été utile ?

Nous sommes désolés de ne pas pouvoir vous aider.

Super ! Merci de vos commentaires.

Êtes-vous satisfait de cette réponse ?

Nous vous remercions de vos commentaires, qui nous aideront à améliorer le site.

Êtes-vous satisfait de cette réponse ?

Merci de vos commentaires

Bonjour

En mettant un format nombre sur une date dans un fichier excel, il ne faut pas être surprise que word en perde son latin à la fusion.

Les formats sont gérés chacun dans leur application.

Donc, dans excel, bien sûr qu’il faut laisser un format date.

Sous word, le commutateur de forçage du format date ci-dessus pour une fusion est correct. C’est même très surprenant qu'il ne marche que de manière aléatoire, il doit manquer des éléments dans votre description.

 

Il y a un autre moyen de forcer les formats dans une fusion word, c’est en utilisant le protocole DDE.

D'abord, dans les options avancées, rubrique ‘Général’, cocher l’option ‘confirmer la conversion de fichier lors de l’ouverture’.

Refaire la jonction de fusion avec le fichier source, choisir le protocole DDE à l’invite. La date devrait être au bon format sans autre intervention.

Argitxu

 

6 personnes ont trouvé cette réponse utile

·

Cette réponse vous a-t-elle été utile ?

Nous sommes désolés de ne pas pouvoir vous aider.

Super ! Merci de vos commentaires.

Êtes-vous satisfait de cette réponse ?

Nous vous remercions de vos commentaires, qui nous aideront à améliorer le site.

Êtes-vous satisfait de cette réponse ?

Merci de vos commentaires

Bonjour,

Je ne crois pas qu'il me manquait des éléments.

Mais j'ai testé ce que vous me proposez. Apparemment cela fonctionne.

J'ai coché la conversion. Lorsque j'ai refais la liaison avec le fichier Excel et que j'ai dû confirmer la source, seule l'option "fichier de base de données ole db" apparaissait (comme d'habitude).

J'ai alors coché l'option "Afficher tout" de la fenêtre et j'ai trouvé le protocole "feuille de calcul ms Excel via un dde".

Merci beaucoup pour la solution

Anelyse

2 personnes ont trouvé cette réponse utile

·

Cette réponse vous a-t-elle été utile ?

Nous sommes désolés de ne pas pouvoir vous aider.

Super ! Merci de vos commentaires.

Êtes-vous satisfait de cette réponse ?

Nous vous remercions de vos commentaires, qui nous aideront à améliorer le site.

Êtes-vous satisfait de cette réponse ?

Merci de vos commentaires

Bonjour,

La solution proposée fonctionne.

Mais lorsque je veux filtrer la base de données à partir de Word, j'ai le message suivant:

"Impossible d'analyser la syntaxe des options de requête dans une chaîne SQL valide"

Ce qui signifie que l'utilisation de "feuille de calcul ms Excel via un dde" ne marche pas sauf si je sélectoinne dans la fenêtre "Fusion et publipostage: Destinataires".

Existe-t-il encore une autre solution?

Merci 

Anelyse

Cette réponse vous a-t-elle été utile ?

Nous sommes désolés de ne pas pouvoir vous aider.

Super ! Merci de vos commentaires.

Êtes-vous satisfait de cette réponse ?

Nous vous remercions de vos commentaires, qui nous aideront à améliorer le site.

Êtes-vous satisfait de cette réponse ?

Merci de vos commentaires

 
 

Informations sur la question


Dernière mise à jour 21 juin 2021 Consultations 13 008 Produit(s) concerné(s) :