Halo 4 Specialization Token Code Not Working

I entered the code that was sent to my email. I still only see the two original specializations. I tried everything that was suggested (delete everything on the hard drive and clear cache, redownload profile, check download history).

There is nothing in my download history and nothing in my PURCHASE history to suggest the code worked in any way. I try to re-enter the code and it says the code has already been redeemed.

This morning Xbox LIVE sent me a message stating that my token had not yet been redeemed and that I should enter my code to unlock. I tried entering the code AGAIN, it told me the code had already been used. Again, nothing in my download OR purchase history.

Xbox LIVE support has been completely worthless. I was tossed around for hours and nothing was accomplished, they told me this forum was the only place my issue could be handled.

Oh, and before you ask, YES I am over 18, YES I live in the US, YES I have been playing since day 1 (preorder), and YES I am over lvl50.

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Sorry but just to clarify,

You inputted the code, it worked (or seemed to work) first time.

You went onto the game to see no additional specialisations.

You were not able to re-download the specialisations or re-enter the code (which you shouldn't be able to do again anyway).

Okay assuming that I have this right,

Did you actually download the specialisations the first time? Are you sure you did not press (B) and leave the redeem prematurely? This would prevent the dlc from downloading (why it wouldn't be in your list) but may also validate the code making it unuseable and therefore impossible to complete the transaction (I realise that support told you it wasn't used but it's not impossible it was. I, also, am unsure if this happens with codes but again it's possible).

Have you tried clearing your cache etc? Or just restarting the game (try starting it up now!)? I had this problem where they would not appear once but showed back up when I played it next time.

I'm sorry if this doesn't help in which case I reckon official support is all that can help (sorry if that annoys you).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.