360 Preview forum access

I am a member of the 360 Preview Program, and am unable to access the 360 Preview forum in order to provide feedback. I contacted support via chat, and was asked to post a message here even though a support ticket was also created.

After registering one of my 360 consoles with the Preview program, I downloaded the update and used the system for about a week in order to provide consolidated feedback. When I first tried to access the Preview forum, I made sure that I was logged in with my gamertag, and received the expected "Group Not Found" error that the FAQ mentioned that I might encounter. Accordingly, I waited 24 hours before trying to access the forum again. I received the same error. I wasn't too concerned at that point, so I continued to use the Preview update and note any issues I noticed while still attempting to access the forum every few days. However, it has now been over a week since I first tried to access the forum and I am still waiting for access.

 

Question Info


Last updated July 4, 2018 Views 8 Applies to:
Answer

Hey there, R06U3! I was able to verify that you are enrolled in the 360 Preview Program, and got you the permissions to access the 360 Update Preview Forums. Please let us know if you need any further assistance accessing that link. Any issues with the preview should be posted in there now. Thanks for the post! :D

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.