Zombie perks not working

Ok, I have played alot of zombies. I could list the levels I got to or the easter eggs I have done but I don't think I need to. Last night while playing with a group of 3 randoms on moon, several things were not right. The excavator that breaches tunnel 6 was supposed to breach in 60 seconds according to the voice but it breached at that point and trapped me. No big deal on taking care of the zombies but the breach was way off. The thing that got me the most was the Mule kick machine would not work for anyone on the map. It was like it didn't exist, no x prompt or anything. I know I could have just said forget it and started a new game which probably would have fixed it. I just want to see if anyone else has had issues with this not working or if it was just a once in a lifetime glitch.

 

Discussion Info


Last updated July 3, 2018 Views 0 Applies to:

Did you have the power turned ON? The power has to be ON for the perk machines to be available. The escavator alerts at the start of a round when and where the breach will occur, but the breach usually wont happen until close to the end of that round. If it was neither of those problems, then it may have been a one time glitch, but theres probably a hidden reason.

The power was on. Escavators won't breach without it being on. Also I had jugg, flopper and quick revive.  We were on round 21. The excavator had breached once around round 15. Same one was going to breach again at round 21. I ran to go stop it and the thing breached right when the computer says, Excavator Pie to breach in 60 seconds.  My guess is it was just an in game mechanic glitch on that particular game. We did have a guy leave so I supposed that could have messed with the coding during that game. I just didn't know if it was just me on that one game or if it happens often. Of the hundreds of zombie games I have played that was my first time the game was glitched that bad.