Xbox won't read Fallout 3

Have tried all of the games that I own and all load on the Xbox however Fallout 3 which worked on my previous generation xbox (now own 250 gb xbox) will not load, instead the xbox says to "eject tray" when the disc is in and connot read it. I have read a couple of post that state after the 7/19 update there is problems with playing certain games on their xbox. I called and went through all the trouble shooting with xbox and the phone operators final solution was that my game was to old and the new generation xbox cannot read the game, that sounds like bull to me as I have plenty of games that are much older then Fallout 3? Anyway I was just wandering if anyone else has had this problem or if there are any xbox reps on here that would give a comment like, "were working on this problem", I am already considering switching to Playstation for next generation do to all these xbox problems, and I don't like thinking that games all of sudden won't work because of an update I am forced to download..... would appreciate a comment that is helpful. Thanks.

 

Question Info


Last updated July 4, 2018 Views 25 Applies to:

Hmm that's strange, I have the xbox slim and Fallout 3 works perfectly well on mine. I have the Game of the Year version, not sure if that makes any difference.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.