Xbox wont let me sign in says I have no storage but I have more than enough (xbox 360 new update)

Xbox 360 has a new update that is required, and it says, "If you decline, you won't be able to connect to Xbox Live until you take the update...". Now I have tried to update it multiple times, but it wont let me because it says, "You don't have enough storage space to take this update. Please connect an Xbox 360 storage device with at least 190 MB free space." I have a storage in my Xbox 360 hardware drive, and I had over 30 GB left which is more than enough to update the system. I tried to access my storage, but when I do it says, "No storage devices found.", which is bogus because its in my Xbox 360 system. I'm kinda *** either way because they wont let me sign in, and then on top of that won't me access my storage at all because I think its linked with my Xbox Live. My internet connection is perfectly fine by the way. 

 

Question Info


Last updated July 4, 2018 Views 203 Applies to:
Answer

Okay never-mind I fixed it. My hard drive was very dusty inside, so I cleaned it out and that was the reason for all of the misconception. It was unresponsive because of the dust. Lol.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.