Xbox One - Play To from Windows 8.1 - Broken with new Router

Hey folks,

I have a couple of Windows 8.1 devices and use the Play To feature to stream videos to my Xbox One console. The featured worked well until I had to replace my old Linksys / Cisco router (WRT310N V2) router with a new Asus router (RT-N66R). For whatever reason, I can no longer "right click" videos in Windows 8.1 and select Play To Xbox One. I suspect it is one of the settings in the Asus router but cannot find anything that should be blocking it. All other features from the Xbox One (connection to Xbox Live, connection to the Internet, etc.) work just fine with the new router.

I looked at the FAQ for Xbox glass here: http://forums.xbox.com/xbox_forums/xbox_support/xbox_one_support/f/4274/t/1628885.aspx

The only setting I see which looks interesting is this one: "Make sure you disable Access Point/WiFi Isolation or related feature on your router."

I don't see a setting (maybe someone can help me) that specifically says AP Wifi isolation is enabled. I'm not connected to a guest network.

Does anyone know where the problem is? The firmware version on my Asus is 3.0.0.4.374_979. Also, if I plug the Linksys / Cisco router back in the Play To Xbox One feature comes back on my Windows 8.1 devices.

Thanks for your help!

Jess

 

Question Info


Last updated July 4, 2018 Views 49 Applies to:

Jess, did you found cause of your problem? Or do you have fix?

I have exactly the same problem. Only new router is Asus RT-AC68U.

And I can't play to only XBOX, but also to XBMC, which worked OK on my previous Asus router:(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I also have the Asus RT-AC68U and cannot get anything to play to my Xbox. It tries to connect, but WMP gives me an "unexpected device error." What do I do to fix this?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

same problem... wishsomebody could offer a solution.  I can connect on my Netgear and use Play To but not my Asus.  The Netgear never required anything crazy to set up, it just worked.

Now with my Asus RTN10+, the Play To is not even an option.  I swapped out the routers a couple times and it's definitely a router problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Figured it out... stupid basic thing that needs to be done again a specific way

Go to Network,  a little banner will show up saying network discovery and sharing is not enabled.... click the banner to enable it and boom everything will populate in the network window.

This should have been done, and should not have changed with the router since it is a computer setting but that 100% fixed it

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there, Duck J13! I'm very happy to see that you figured it out and are up and running. If you run into issues in the future, please post up a new thread detailing what you're running into and troubleshooting you've completed. This way our community can get you the individual support that works best with the forums. :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.