Xbox 360 YouTube App is Broken

  Since the last update to youtube (The one that completely changed the UI for browsing youtube) I have been having numerous problems with the service. 1.) Upon loading, youtube will only load half of the thumbnails for videos and channels, if even that. 2.) Videos will only play about 40% of the time, and usually I have to select the video multiple times back out, then select it again for it to play. 3.) It cant seem to decide what is wrong with the app, I get error messages that range from error codes, to "Requested video cannot be retrieved" (sometimes after the video has started playing and continues to play with the error message overlayed in front of it) as well as Network Errors. 4.) Upon opening the browse menu displayed at the side of the screen, most of the time nothing is there or it only partially loads. I have tried completely removing all traces of YouTube from the console and reinstalling the app, and it has yielded no results. I can also say with almist 100% certainty it is not my ISP as everything else for xbox that requires internet works perfectly fine, as well as everything for every internet capable device in my house. The issues are entirely exclusive to Youtube on Xbox 360. Please help! It has been happening since the update months ago, and I am fed up!

 

Question Info


Last updated July 4, 2018 Views 7 Applies to:

I was beginning to think that I was the only one having this issue. At least now I know that I'm not.  I've been searching for a fix for days.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.