Xbox 360 Streaming Music Issue

Ok, I'll try to be as specific and too the point as possible...

I just noticed that for some reason my shared music is not showing up to play through my Xbox 360.  When I go to "Media > Select Music" my PC shows up correctly, but when I click it, then try and find some songs, albums, etc - it says No albums found.

Now on the PC end (Windows 7), when I check my media streaming options through my network, my Xbox 360 is allowed through, sharing up my PC is enabled.  I even tried connecting with Windows Media Player open - there's an option above your playlist to "play to" and it shows my Xbox 360 and my songs in the playlist.  But, when I it play, soon every single song gets an error "failed to retrieve media information from media server."

Please help, this is driving me insane!  I have no idea why it's not working, it doesn't make any sense, as well as it has always worked, and I haven't changed any settings.  

 

Question Info


Last updated July 4, 2018 Views 9 Applies to:

I figured it out.  

Just in case other's have this issue, I needed to navigate to "Services" on my PC - then stop my Windows Media Player Network Sharing service, then stop my UPnP Device Host service, the restart UPnP Device Host, then restart Windows Media Player Network Sharing service.  That did the trick!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there

Glad that your problem is resolved, feel free to post back if you havr any further questions.

Regards

Volunteer Moderator | Xbox Ambassador | Article Author | Windows & Xbox Insider

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.