XB1 doesn't like my Sony tv, what a suprise !

So here's the thing, I've set up my XB1 on a Sony Bravia KDL 40S5500 tv to run live SKY TV through it, every now and again, not all the time, but more frequent than not, the picture will go black for a second or two then come back, I've tried everything to resolve it barring buying a new TV, which I do not wish to do, so heres the check list........

Made sure all HDMI leads are in the relevant ports and are firmly secure

Checked all HDMI ports on the TV to see if the problem persists, which it does.

Swapped HDMI leads in the back of the XB1.

Tried a different HDMI lead aside from the one in the box.

Changed the output of the SKY HD box from 1080i to 720p.

I'm at my wits end, so if there is any thing else I should be aware of or I am missing please feel free to enlighten me.

Many thanks in advance.

 

Question Info


Last updated July 4, 2018 Views 536 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

[quote user="Macabre1980"]

So here's the thing, I've set up my XB1 on a Sony Bravia KDL 40S5500 tv to run live SKY TV through it, every now and again, not all the time, but more frequent than not, the picture will go black for a second or two then come back, I've tried everything to resolve it barring buying a new TV, which I do not wish to do, so heres the check list........

Made sure all HDMI leads are in the relevant ports and are firmly secure

Checked all HDMI ports on the TV to see if the problem persists, which it does.

Swapped HDMI leads in the back of the XB1.

Tried a different HDMI lead aside from the one in the box.

Changed the output of the SKY HD box from 1080i to 720p.

I'm at my wits end, so if there is any thing else I should be aware of or I am missing please feel free to enlighten me.

Many thanks in advance.

[/quote]

If video sourced by the XB1, i.e. video from apps, games, etc., is fine and only the passthrough video from the STB is giving you problems then welcome to the bleeding edge.  There are literally hundreds of reports of this problem and I suspect they are due to code deficiencies in the Watch TV app.  Not unexpected in a version 1.0 console.

 

There are some that have decreased the problem via various methods.  Check around this forum for other threads involving the TV.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Unfortunately this happens not only with live tv but with everything, the home screen, games, apps the whole bang.

And not being funny, taking into account it is ver 1.0, but for £429 I would have expected it to perform a little better than it does,  sigh, hopefully a patch will be along soon as I begrudge spending any more money on a new TV just for a black screen to stop popping up

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

A new TV likely wouldn't solve your problem.  There are a lot of problems being encountered by those attempting to run the XB1 in a 50Hz system. Someone has managed to 'fake out' the XB1 so it puts out 50Hz but a lot of other problems crop up.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My kdl 40s5500 doing exactly the same. Every few mins screen goes blank for a split second. Actually thought it was my tv that was at fault and was prepared to buy a new one but this forum now gives me hope. Surely microsoft can release an update to us to prevent this. If not then they should of specified that we needed a 60hz to be able to use an xbox one. Also not happy about not been able to play sky tv through it at 50hz. Americans looking after themselves as usual, surely they know europe run at 50hz. Can see myself buying ps4 if things continue

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have apparently 'solved' my Live TV problems and am sharing my 'solution'.  I have no idea if my 'solution' will work for others.  To save retyping, I will copy my last post to a thread I started about my problem, but first an observation:  

 

I wonder if the problems are caused by low signal levels out of the STBs.  By placing a powered splitter in line the only thing that I have really changed is to ensure that a high level signal is present at the input of the Xbox One.  Just a thought as I have no means of measuring signal levels, but this could explain why some have had success changing HDMI cables (I didn't).  If my supposition turns out to be the case it may indicate a defect in the XB1's HDMI input or maybe the STBs are not up to par with their HDMI output.  Here's my 'solution' post:

 

 

It appears as if I may have 'solved' my freezing problem and to a certain extent my picture quality problem.

 

I can't claim any superior reasoning in my solution.  Between testing Live TV and switching back to connecting my STB directly to the TV I became rather tired of the process required to switch the STB HDMI output to the Xbox One HDMI input so I ordered a one to two powered HDMI splitter from Amazon.  I figured that I could use one output for testing and the other to 'really' watch TV.

 

I connected the STB HDMI output to the input on the splitter, ran one output to the original TV HDMI (4) input for the STB and ran the other splitter output to the HDMI input on the Xbox One.  The Xbox One HDMI output goes through a 2 to 1 switch.  The other input to the switch is my Xbox 360.  The output of the switch goes to HDMI 3 on my TV.

 

Since I installed the 1 to 2 splitter I have had absolutely no problems with the TV signal.  I know that I've only been at it ten hours or so, but in that time I haven't had a single freeze or even a minor hiccup and I couldn't go two minutes without a hiccup prior to installing the splitter.

 

My XTB is set to 720p, HDMI audio.

 

My settings on the Xbox One are:

 

  • Troubleshooting->Surround Sound(Beta) is checked.
  • Optical audio is set to DTS Digital Surround.  This audio is routed to my Logitech 5500 speaker system via an optical switch. I do not use the HDMI audio from the XB1, but the XB1 HDMI audio is set to 5.1 uncompressed.
  • Power mode is set to Instant-on

 

If the failures start happening again I will again post to this thread.  If you don't see an update from me then the setup is still working well.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The problem with my kdl 40s5500 turning to a blank screen every few mins is because the tv cannot handle the 60hz signal its receiving from the xbox one both when playing games & watching tv through it. The tv is a 50hx tv hence its not compatible. Microsoft have made a massive error here. We have basically been sold a product that is unfit for purpose. Surely research tells them the UK run on 50hz system and not 60hz same as USA. We need to hope they release a patch to enable us to run at 50hx all the time and lose no quality.  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This has happening to me also. Its actually very similar to an issue with my HTPC which would do this until I updated the firmware and video card drivers. To be clear this happens in all games and also when watching TV. Sometimes the TV overlay pops up like I have changed the source or something. My TV is a Sony KDL-4025500 (which is the same as DMCHAPMAN13) I know this TV doesn't support 1 to 1 pixel mappings so the xbox has to change the over or under scan and resize. Same issue with my HTPC when connecting directly I have to "resize" desktop as its over scan by default. The xbox 360 could handle this so it should be solvable.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Decided to buy a new samsung led f5000 model anyway. Ended up getting £200 for my bravia. Difference in quality now im running my xbone on a compatible tv is astonishing. Hope microsoft still release a firmware update though as i still cant play my sky.box through xbone due to trying to broadcast a 50hz signal in 60hz format

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

£200 that's a pretty good price, where did you get that?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

UPDATE !!!!!!!!!!!!!!!!!!!!!!!!

Ok after about a month of scouring the net on a possible solution I think I've finally cracked it..........

My problem was that I was getting a black flickering screen on my Sony Bravia  KDL40S5500 whenever my Sky HD box was plugged into the back of my Xbox one, not all the time but more often than not.

After doing the steps that I will post in a link down below, I have no longer got the problem of the screen flickering black .

Give it a go and let me know your outcome people.

Hopefully it works for you guys and gals too.

So far its been on 2 hours at the time of typing this and not one flicker yet

Hope it helps

Link : support.xbox.com/.../offline-system-update-diagnostic-tool

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.