Witcher 3 - Won't Launch, kicks to dashboard

Hi,

Bought the game on Tuesday. Installed it, pressed to play. Initially, it immediately kicks me back to the dashboard, with only some controller input delay. Press it a second time, and manage to get the initial splash screen of Geralt, then a black screen, and then kicked back to dashboard. Massive input delay/crashing e.t.c. 

When I've managed to press play for the third time, I get this weird bug where the splash screen becomes part of my dashboard, with it being the central screen...

I've tried hard reboot, reinstalling/installing the game, unplugging the console and even replacing the disk. Still the same problems. Any ideas? It's torturous having the game in front of me and not being able to play it.

 

Question Info


Last updated July 4, 2018 Views 31 Applies to:
Answer

The Dark Souls 2 thing might be related to something else.

Yes, the system update is required in order to run disc based games. Additionally, if your console is not connected to the internet, The Witcher 3 might need an online update before it can launch fully. I suggest updating your console and then giving it a shot then. It might also resolve the issue with the Dark Souls 2 tile not moving.

Let us know if that works for you! If not, we'll definitely dig a bit deeper. :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.