Windows 8.1 XBox Video Metro App video/audio sync/lag issue

Since updating to Windows 8.1 last week (perhaps this is a coincidence, although I doubt it), the XBox Video app no longer plays most content correctly. With downloaded or streamed videos (e.g. The Hobbit), the video lags the audio by up to a few seconds.

Other videos, not obtained through the store, play fine. 

The videos played perfectly before the update to Windows 8.1. I am using the latest app version as of the date of this post. It was updated on Feb 14th; perhaps the problem came with the latest update. One weakness with an app approach is that there is no way to revert.

The most relevant specs are:

Asus M3N-HD HDMI mainboard with Athlon X2 5000 dual core chip
4 GB DDR2-800 RAM. 
Kingston SSD
nVidia GeForce 9500 GT
Creative sound card/integrated HD audio both have the issue.

I changed video cards (From a 9600 GT) and sound cards, and it did not help. nVidia driver update did not help. No updates available in Windows update. "App repair" did not work.

Netflix HD content plays perfectly. It seems to be only the XBox Video app.

Any ideas?

 

Question Info


Last updated July 4, 2018 Views 2 Applies to:

Well I found an alternative, for now, as I am just switching to iTunes. I can't build a media library with a system that isn't reliable, and there is little recourse here.

My guess is that it has to do with DRM content, as the Zune PC player has the same issue. iTunes HD plays fine, however, and all the same content worked before the 8.1 update.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Unfortunately, no help yet.

I am increasingly convinced it is DRM related, as trailers seem to play fine.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I reverted to Windows 8. The Xbox Video works fine. The video no longer lags and is out of sync with the audio. So Windows 8.1 broke something.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You can try to re-install the application there must be a incompatibility with Windows 8.1 and sometimes are the reason on why you're not able to play these movies (content). If there's any problem with it. Microsoft will surely release an update for their application to match with Windows 8.1

Bug fixes! Cheers!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the suggestion. Unfortunately, reinstalling the app did not fix it (I tried it twice). Since the same behavior happens with DRM content in Zune, it must be some combination of Windows 8.1 + chipset + video + their codecs + etc.

Reverting to Windows 8 was a doable workaround, albeit very inconvenient. I will avoid any upgrade to 8.1.

I hope you are right, but it is difficult to tell whether MS is paying attention. I cannot find a workable way to submit defects.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.