Windows 8 Xbox Music app won't recognize library-mounted music on an external device.

I originally posted this in the Microsoft Community but was told that I might have more luck on here.

 

I have all my music on a 64 GB SD card that I keep in my new Lenovo Yoga. I have it mounted to my Music Library so that Zune recognizes and adds everything in my SD card to my Zune collection as if it were there on my SSD, freeing up 40+ GB and counting. This device only has 128 GB of SSD so this was necessary. Zune picks up and plays the music flawlessly.

 

Now, I want to be able to use Xbox Music to play my music because the pause/forward/back and info when you press Volume is very nice and I'd like to be able to use that, but Xbox Music isn't picking anything up from my Music Library the way Zune does. Zune works perfect with it, why can't Xbox Music?

 

 

Question Info


Last updated July 4, 2018 Views 23 Applies to:

Hi Dr! Have you added your SD card location to your Xbox Music app?

To do so, please follow the steps listed below..

  1. At the Windows 8 default screen on your computer, find and click the Desktop tile. This will take you to the classic desktop view.
  2. Select Windows Explorer (the manila folder next to the Internet Explorer icon).
  3. Under Libraries, select Music.
  4. Right-click Music, and then select Properties.
  5. Click Add.
  6. Include the folders where your music is stored.
  7. Click OK.
  8. Close, and the re-open the Music app.

 
Let us know if that works for you! 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem as the above posted and the solution did not work for me. I already added this directory to the Music Library and the Windows 8 Music app does not detect any music (I'm on a Surface Pro, but we're both running W8).

When I browse to the Music library in Windows Explorer, the albums and directories all appear in the library normally. It seems the Music app is the only thing that CAN'T see these directories. Is there a way to force a detection? Restarting the app doesn't do anything either.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey Verge. Do you know what format your songs are in?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same problem. I sees all of them as "Unknown Artist", even though they are foldered under the artist than album. Most are mp3s.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hiya Sarah. Go ahead and navigate to those song files, right click, and choose Properties. Click on the details tab, and make sure the Artist field is properly filled. Let us know how that goes, or if you need anymore help. Cheers!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have a similar problem... I am trying to get the xbox music app to 'see' the music on my NAS. I got that sort of working by creating a 'symbolic link' between my library and the network location... (you are not making things easy...)

But now the win8 XBOX Music app only shows some of the albums. I am guessing that only the albums that are available in the 'store'  show up but somehow there must be a way to get them to show up? I own this music after all... THe weird thing that I can actually navigate to the files from within the app ('open file')  but then I get some sort of uncomprehensible error message. Any help/suggestions? thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same issue.  I was hoping today's music app update would solve it, but it hasn't helped.  

I have music on an SD card; I added to my music library in explorer and most albums show up in the Music app, but not all.  I can navigate to them and play them using "Open File" from within the app, but even after playing they still won't show up in "my music" in the app.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same issue here on a Surface Pro. I have all my music on an SD card and have added it to the Music Library, but the Xbox Music App is not showing these songs in "my music".

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the exact same problem on the surface rt.

They are all there in the music library but they don't show up in Xbox music.

Tried Nokia music to see if that would work and it didn't.

the really strange thing is that I added some files a few days ago and they showed up but when I copied a second wave of files to the same location they didn't.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey folks. This thread is getting a bit convoluted, so if you need help, please go ahead and create a new thread. Thank you!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.