Windows 10 Game DVR unspecified error

I can't record or save screenshots with the Game DVR on Windows 10. I get the messages "Can't record right now. Try again later." and "Can't save the screenshot. Try again later.". Also in the Xbox app, in the "Game DVR" tab, under "on this PC" it says "Something went wrong with loading this info. Try again later. Unspecified error". My video card is NVIDIA Geforce GTX 960. I installed the most recent update, version 355.60. I also tried rolling back the driver to the second most recent driver. Xbox app is 7.7.29027.00000. In the Game DVR setting, everthing is switched to ON. Win+G does bring the bar up it just gives me error when I try to record. Win+alt+r also seems to start recording but after 10 seconds I get the error message.

 

Question Info


Last updated July 4, 2018 Views 708 Applies to:

I have the exact same issues and error messages. Video card AMD Radeon HD 7700 Series.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I solved this issue for me. I simply moved the "Captures" folder to C: drive (drag and drop the actual folder -- there's no way to create a new folder for GameDVR). Make sure it's not under your account name. Once I did this, it worked again. Was having the exact same issue.

Where is the C: drive folder? I am having the same problem, and would love to fix it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I solved this issue for me. I simply moved the "Captures" folder to C: drive (drag and drop the actual folder -- there's no way to create a new folder for GameDVR). Make sure it's not under your account name. Once I did this, it worked again. Was having the exact same issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.