Weird "Failed to Connect to EA Online" situation.

I've searched through a few of the other threads about the EA situation, but none solved the problem for me (though I haven't messed with the port settings yet).

My dad has been having problems connecting to EA Online for the past week or two. At first, I figured it was just a minor issue with the servers or maybe just our Internet connection, so we reset the router and it worked...for a while.

However, today he goes to play and cannot connect to EA Online, even after resetting the router. Since we both have our own Xbox 360s, he took mine and tried it out and it worked fine. I tried his and it wouldn't connect. We also tried using the same ethernet cord, and once again mine worked but his didn't. His Xbox connects to Xbox Live with no problems though.

Does anyone know what might be causing this?

 

Discussion Info


Last updated July 3, 2018 Views 0 Applies to:

Have you configured the ports for his IP on the 360? Are they static IPs for each one? Have you tried the date changing suggestion in other EA Online problems?

Gremlins?

Being serious, mine has been funky the last week or so. I just grin and bear it. I'm not tech savy enough to fix the problem.

Servers are fine. I played a couple matches today with no problem.

Previously known as Win7Xbox 360

Its been happening all week. Sometimes you can get on with no problems, but most of the time it doesnt connect. Ive been trying for the last 20 minutes or so to connect.  Its so annoying, and its totally random (3 people on my friends list are on right now, dominating no less), while I keep trying.    Hope they figure this out before BF3. 

Talked with an EA rep that had basically the idea that servers have been undergoing maintenance for the past week.  I have NEVER had issues with being unable to connect to EA online servers for BF:BC 2, except when the game was first released.  I have tried every single fix out there.  This effing sux EA!  And Todd, if you're reading this, you seriously need to ask for more information so I can know exactly what is going on.

Keep these posts bumpped there is clearly a problem been 4 weeks now for me.

I am having these problems as well. I have tried all the tricks, setting up the ports everything. I read a couple of posts on a different forum that said the EA servers are all messed up so it might not be just a problem for a few of us. I think its happening to many people