Under xbox,xbox beta app , wont start AoE :Castle Siege

First of all i tried everything . Now i gonna loose my mind . Really , upgraded to windows 10 and now i can't play with Castle Siege on my laptop.
When i start the game it pops up the loading screen for a second than gone . Try to upgrade windows 10 , xbox application upgraded as well . Nothing worked .
I reinstalled 2 times the game or more . Than i tried solve the problem with original install windows 10 . 
Nothing worked. Other games are working fine only this one not . Help a little bit out here please ! Many thanks !

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Hi Soul,

It sounds like you're launching Castle Siege through the Xbox app? Could you instead try launching it from Windows, without going through the Xbox app? Hit the Windows key and type "age of" - it should be near the top of the list, simply highlight it and hit Enter.

Does the game load now? Let us know how you get on.

Xbox Forums moderator. Xbox MVP. r/xboxinsiders moderator. Twitter: @13mxn

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.