Unable to play Fable III

Bought the game a couple days ago, and proceeded to the title screen (after installing all the updates needed for the Xbox and the game itself), and received this error message:  "Storage device removed!" "The storage device containing the current gamer profile has been removed! You won't be able to earn Achievement if you don't reinsert the device the gamer profile is stored on." with the following options: Recheck for gamer profile, Continue (no Achievements), Quit to the title screen.


Problem is, the HDD has never been removed from the Xbox. So I tried rechecking for the gamer profile, and it tells me no profiles exist (which has to be untrue because I was previously able to play Halo:Reach without any problems, and I have achievements to prove it). I also tried turning the Xbox off, taking out the HDD and making sure no dust had got in the way, putting it back in and turning on the system again, and still had the error.

Note; I logged into my profile and Xbox Live from the dashboard just fine, and while on the title screen the dashboard still shows me as logged in.

I am though currently not subscribed to Xbox Live Gold, I want to be sure it is going to be used before I use my code. I assumed I could connect to Live just enough to fix my profile if that was the problem.

Thanks for the help.

 

Question Info


Last updated July 4, 2018 Views 42 Applies to:

Hey Savierya.

Could you try recovering your profile.

Turn on your console and make sure no profiles are signed in, then press the xbox guide button (large circular button in the centre of the pad) and select recover profile/account.
Then follow the onscreen prompts.

(You need your profiles wlid and password to recover).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.