Unable to load Multiplayer - Server Unavailable

Looking for some help/advice.

I’m trying to play multiplayer on Assassin’s Creed Brotherhood but when I click on Multiplayer and it gets to the screen saying “Loading in Progress”, the symbol freezes and then I get an ! on the screen followed by a message saying the Ubisoft Server isn’t available.

I’ve looked around and tried the following but still nothing…
  • Cleared the cache
  • Removed title update and updates and re-downloaded them
  • Checked my xbox live settings (other games working fine online)
  • Added the recommended ports to my router
  • Tried a different Gamertag
  • Tried a different copy of the game
The thing I find strange is that I’ve tried it on my partner’s xbox and it works fine. We’re both using the same router/internet access and I’ve connected on it using my gamertag, which would suggest there is a problem with my xbox and not the connection.

I’ve tried it wireless and wired but still no good. I know someone’s going to turn round and say just wait until the Servers are working but I know they’re working right now but I’m still getting the error message. This also applies to accessing UPLAY from the start menu.

Someone please help!
 

Discussion Info


Last updated July 3, 2018 Views 3 Applies to:

im also having this trouble. its the same for Uplay Exclusive content and multilayer

Try this:

Go to your settings, game settings, find AC Brotherhood, find Title Update 5. If you have that, delete it. Put the game disc in, it will search another better update for you. That'll give you Animus 3.0 and you should be OK from there.

I had this issue myself and it took more than 3 hours for me to find the solution. I hope this helps. :-)

any adice if it doesn't work when it is downloaded

tried geting update 3 but it keeps getting update 4