Unable to join party - Help please!

Me and my friend are trying to play halo reach together, but we are unable to join each others parties.

- Both our networks are OPEN NAT
- We have tested connection to Xbox Live and both work perfectly
- Have tried resetting routers
- We can connect to other friends games
- Reset Xbox to default factory settings
- Have good connections
- We live only a few blocks away from each other with the same ISP

 

Question Info


Last updated July 4, 2018 Views 1 Applies to:

Hello,

I recommend you to try these steps that are been given and explained right here:

support.xbox.com/.../performance

There are sure some steps that you and maybie your friend too tried those steps.

Just complete all steps.

If none of those works, try solution 8 and if that didn't help, try step 7.

If none of those steps worked, please reply back.

Thanks.

Met vriendelijke groet,

Rick N.,
DummyArbiter010

borntolearn.mslearn.net
microsoft.com/learning

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.