TV's That Create Gaming Lag

Guys and Girls,

This is a pain in the backside. I bought an LG 42lw450 TV 42inch 3d. I really shouldn't have. Playing a game on this TV causes about half a second Lag. Watching normal tele on it is fine. But gaming is a joke. I'm currently trying to get my money back. The picture on this TV is second to none and will enhance the video clarity, but at a cost of half a second of lag. It's unplayable and very frustrating. This is a warning to not get one of these TV's and please guys, NAME ANY TV THAT DOES THE SAME. Plus I rang LG and their response "its acceptable and to spec for 0.5 seconds lag".......OOOOHHHH no it isn't

I am in need of another TV now so post please any good TV's that are good that dont generate this lag (42inch)

Plus I Tried "Game Mode"  on the TV

More info on this site  http://lgknowledgebase.com/kb/index.php?View=entry&EntryID=3012

Thanks,

Bravestyogi

 

Discussion Info


Last updated July 4, 2018 Views 0 Applies to:

Anybody looking to invest in a TV need to check out the AVS Forums for more information.  There is a wealth of information on that site, and people who know a lot.  They can spot minor differences in black levels, and they can be really picky, almost to the point of being annoying.  But hey, it's a good place to do research.

Im running a Samsung 50" 6400 series plasma.   Excellent color, bright screen, no burning issues, no lag issues either.

Great gaming tv, IMO.

try turning off all picture enhancements see if it helps.

don`t have any levels excessively high,e.g 100% contrast etc.

the more gadgets you have on the more the lag will occur.

i have a philips lcd that works perfectly,its only a 32 inch though.

Yeah so many of the larger HD TVs have image cleanup features so standard definition material doesn't look so incredibly horrible. For games they need to be turned off and there should be no lag. Blaming it on scaling for the 360 isn't an issue since it does image scaling on it's own and if the TV can't handle scaling or interlaced inputs then it's a poor display. Also game mode doesn't always turn off every post processing feature. Need to go in turn the rest of them off.