TV sound only in stereo

Ok this has been driving me bonkers since launch. My setup is as follows

Virgin tivo into xbox one into Sony str dg820 av amp into telly, all connected via HDMI. 

I have tried every setting combo I can think of and am still only able to get stereo when watching tv. Sound on the xbox is fine and I can have it in 5.1 or DTS and it all works but as soon as I put the tv on it just outputs it in stereo and my amp won't allow me to mix it into any other speakers. I've tried the surround beta but it makes no difference I even have the new beta update and still no joy.

Has anyone else encountered this problem with virgin TiVo or am I just being stupid. Any help would be appreciated.

 

Question Info


Last updated July 4, 2018 Views 9 Applies to:

Anyone?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the exact same issue.  Virgin TiVo going into Xbox one via HDMI, then HDMI to 5.1 receiver, then HDMI to TV.  No 5.1 from the Virgin TiVo movie channels, but everything else is fine.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There is a fix currently in the April update preview for this.  It was listed as a resolved issue two builds ago:

Fix for LiveTV audio outputting in stereo instead of surround sound.

Once the release goes GA (sorry I don't know when this is, we don't know until usually a night or two before the push) the issue should be resolved for you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am still only getting stereo for TV.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There are TWO place where you have to change the setting to Surround. The first is in the main audio menu, which I assume you found.

Next you must go to the "TV and OneGuide" setting section to enable surround sound for Live TV.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks to "adamleibo" for the best answer, fixed my problem!

"There are TWO place where you have to change the setting to Surround. The first is in the main audio menu, which I assume you found.

Next you must go to the "TV and OneGuide" setting section to enable surround sound for Live TV."

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there, Copper949! Thanks for letting us know that you're all fixed up. This thread is over a year old. If you need assistance with any other support issues, please post up a new thread detailing what you're running into and troubleshooting you've completed. This way our community can get you the individual support that works best on the forums. :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.