Tried playing MP this morning

So I havn't been able to play ME 3 multiplayer since October due to things going on in real life.  So this morning I decided to play a little ME 3 multiplayer just get back into the swing of things while I run the Shepard I am working on through the first two games so I could have a decent galactic readiness rating by the time I import them into ME 3.  I decided I would try a bronze match with my Krogan sentinel just to get back into the swing of things but the problem was while I was just staring at loading screens I kept getting messages about getting kicked while I didn't even get a chance to see what Lobby I was in.  Needless to say after a few attempts I just went back to working on my Shepard who is in the process of wrapping things up in ME 1.  Now I have been out of the loop with the ME games since October (havn't even had a chance to play Omega yet) and especially the ME 3 multiplayer, but was this something on my end or were the servers just acting weird?  

 

Discussion Info


Last updated July 3, 2018 Views 0 Applies to:

The servers not being properly maintained imho. The last week or so, I've been getting disconnected a lot from games in progress (One particularly painful one, happened in the last 4 seconds of a Platinum match... lost all the credits >.<). Now with BioWare not doing anymore weekend operations and (according to NPlewes on the BSN) " the servers and challenge systems will keep running as long as we can keep them up ", doesn't really fill myself with confidence that the MP servers will undergo regular maintenance to work out these disconnection hiccups.

Is it possible that he's missing some free dlc that might be making him drop from matches?

Wouldn't be able to join a match without the relevant DLC though...

Yeah, if he hasn't played since October he's missing at least 2 DLC packs that would be required for play.

Oh I updated all the DLC a few days ago though I had to redownload everything due to the fact that my xbox was stolen in October but I have everything updated.  I did manage to get in this morning so it was probably just the servers acting weird.

EA servers are "okay", but sometimes they get so messed up that I have to wait a hour or two before things return back to functional levels  :)