Trenched - Xbox Reading error

Xbox 360 Slim 4GB Model - Brought under a month ago.

 

I recently acquired the game 'Trenched' via the Xbox Marketplace - Every time I try to play the game I keep getting the

"Disc is unreadable" error, So had a good read in the FAQ and done a search and completed the 'Clear Cache' trick. I then tried to

play the game with a little luck I sometimes manage to accomplish 1 full level with other players where as 80% of the time the game

has a Insta-Error related to unreadable disc.

 

-Now i must be thick or I am obviously missing something here but because the game and content was and is downloaded + Installed onto my

Xbox hard drive (4gb Xbox Slim) with only not even half of that memory used, How is it that the game can be scratched - Shouldn't I be getting

some other error rather than a 'Game disc' type error?

 

I also tried using a USB memory drive and formatted it (16gb) and then moved the game and its content from the Xbox Hard Drive to the USB Memory

and still get the same problem - Except only this time I get a error half way through every game I play then it quits and bring me back to the dashboard.

 

Redownloading the game isn't a option on a 10gb/month download plan - Until next month. So that is an invalid idea at the moment.

 

Question Info


Last updated July 4, 2018 Views 5 Applies to:

Unfortunately, mate, the solution you can't try right now is the one most likely to resolve the issue. Could you possibly take your console to a friend's house, to re-download on their network?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.