Titanfall trouble/ 780 Mb update after installation stuck at 100%

Hey. I have tried multiple discs of titanfall in my Xbox one. The first one installed fine, but it had the multiplayer loading screen issue where you couldn't find a game. I returned the disc, and uninstalled. I then put in the new copy of titanfall in and started installing it. The initial installation took no time at all, just about... 20 or 30 minutes, which was a nice change from the first disc which took hours. Anyways I then started downloading the update for titanfall which is either 780 or 800mb or whatever... And the update took hours, and once it got to 100% it just stayed there... Forever. I tried pausing and resuming the download, even powering off the console and turning it back on, the cold start method, taking the disc out and reinserting it. Nothing worked. I'm wondering if its my console or if all the discs in our area are faulty or something. I dont wanna keep going back and trading the game in for another copy, so I was hoping someone on here that knows their stuff could help me out. I really like the Xbox one so far besides the faults in finding, and I dont wanna give up on it yet, so any help would be greatly appreciated.
 

Discussion Info


Last updated July 4, 2018 Views 2 Applies to:

when i put my disc in to install, it said there was an update before it intalled not after dont know if that has anything to do with it

When I got home with Titanfall and put the disc in it took me 33 minutes to install the game and download/install the update. If the update is taking hours to download/install - that sounds like an internet connection issue to me. I would make sure your connection is good and then uninstall, power cycle, reinstall. Good Luck!