Titanfall issue, stuck at retrieving matchmaking list

So since ive gotten this game ive been having problems. At first i couldnt play at all. After hours of waiting i found someone that said to try rebooting my modem. i tried that and it worked. But then i get off for dinner and get back on and the problem is back. The reboot fix did not work this time. But when my friend invited me i was able to play so i just thought whatever. now the forth day this game is out and i have the same problem still. I rebooted my router again but now i was able to get in but in a brazil server. I just want to play titanfall in my eastern US server. can anyone help ? is it my xbox ? or maybe because i downloaded the game and dont have a disk ?

 

Question Info


Last updated July 4, 2018 Views 282 Applies to:
Answer

Ok, thought I would follow up on this.  After digging for awhile it seems that older Belkin routers seem to be at the root of the issue.  Still not sure what the problem is exactly....

I got around this by opening setting on the xbox, nav to network >> advanced settings >> for dns select manual >> enter as primary 8.8.8.8 and 4.2.2.2 as secondary.  When I supplied 4.2.2.2 as primary this fix did not work ... so you might have to try reversing these if it doesn't work for you immediately.

Hopefully these setting changes are relatively passive and do not effect future online games....

incidentally, I am mildly worried that incompatibilities are left for the user to sort out ... I would be happier with a route cause and a workaround/fix from the company(s) supplying the game solutions.  I do not want to have to buy new networking hardware for every game that comes out potentially or have to go through this again for that matter.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

for anyone having this problem this is what helped me ! getsatisfaction.com/.../titanfall_router_workaround

going network settings and manually making my primary and secondary DNS 4.2.2.2 and 8.8.8.8

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.