this game is now a loading screen

when the dragonborn dlc was released for skyrim i download it for 20$ and played ii. it was a good dlc.  the only problem is that i wasn't able to finish it.  when ever i start my game and load my save it sits on the loading screen forever.  i then tryed to load a different save. dosent work.  a new save. nope.  I'm kinda pissed off because i spent over 100$ on skyrim and i cant even play it.  I'm not sure if this is the correct spot to put this cause im new to the forums but i wanted to return to skyrim today because my friend has been playing it lately and i cant.  please get back to this as soon as possible.

 

Discussion Info


Last updated July 4, 2018 Views 1 Applies to:

I would say try clearing your cache, but other than that, I don't know.

Start a new game, then load the save you want to load from in-game.

.

Try that.

i cant start a new game

You can't start a new game even if you restart your Xbox? Do you not get to see the title screen?

You may want to re-install everything and then try to start again. Clearing the caches is a good idea also.

I know this is going to sound harsh but did you have the disc in the X-box?

Also consider deleting and recovering your profile, perhaps. Pretty severe issue if you can't start a new game.

the loading screen never ends

I have the exact same problem but with hearthfire dlc :(

I've been having this problem as well. I saved my game while in the soul cairn and exited. when I open up the save, it stays on the load screen. My friend and I have tried a bunch of different things. I cleared both the game cache and system cache. I tried to start a new game and load my old save. I even let it sit for about an hour and a half with no avail. I made the stupid decision of deleting all of my previous saves on my character. I really don't want to start a new game. It's the farthest into this game I've ever gone...