The disk could not be read when loading the map "Corvette" on Halo Reach

I can do everything else in reach but when ever I try to play on the map "Corvette" My Xbox says to clean the disk but I don't understand because My game is installed to my HDD... I've tried reinstalling it and cleaning the disk. I've even tried to play without my HDD attached to my console, still nothing. It's not too bothersome just inconvenient. I believe it is only the map "Corvette" but it might be my Xbox since It has a bunch of ether problems that I just suffer through (like constant freezing and crashing) because I can't afford to get them fixed. I very much like to know why it does this even though I have the game installed.

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

This is certainly odd. To be sure, have you purchased and downloaded the corresponding DLC pack with your account?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.