Stupid Bloodskal Door!!!

I have been putting off this quest (in fact, it was my frustration for this gate that made me stop the DLC) and have come back to it, but I still CANNOT get past this door!!!

 

Have watched various YouTube videos, read other site posts and even used the Skyrim Wiki for this quest, but nothing is happening for me!

 

And before anyone asks, I have been using the horizontal/vertical power strokes on the appropriate fissures and got all the way to the final one at the top of the arch, but could NEVER get it to work! 

 

Now have returned to this dreaded quest in Legendary Mode (not that it should make any difference, right?)  My Wood Elf is level 123 playing on Legendary difficulty and now can't even get past the first fissures. 

 

Is something supposed to happen when the fissures are activated by the energy beam?  I know you need to activate both sides separately, but this time, nothing is happening.  I have swung at point blank range and near Gratian Caerellius' remains - no results.  Even when the beam hits the crack exactly there are still no results.

 

Did Bethesda put this quest in the game just to drive me INSANE or was there some twisted methodology to this madness???  I hope I'm not the only one this quest is driven to the brink!

 

Any hints on how to solve this dilemma?  Or am I DOOMED to remain ignorant to the loot just tempting me beyond the door??? 

 

HELP????

 

Discussion Info


Last updated July 4, 2018 Views 6 Applies to:

It made me crazy too. It requires a power swing and, as we all know, I don't use a sword because I swing one like a little girl. i had no difficulty with the top but the first two sideways ones did me in multiple times. You are right that difficulty shouldn't matter on a puzzle but maybe you could try it on easy just to get past the benighted door?

Sargon, this one was hard but not impossible for my Nord swordsman/archer. The door was hard for me to get past as well, persistence (and maybe a tad bit of luck) like you exhibit got me through. I had all two handed perks at the time, and the Bloodskal Blade is two handed if I recall. Did the wiki mention any bugs for that door?  

The door was just the beginning, once through Zahkriisos lies in wait. He was one of, if not the toughest DP I encountered in the game. Highlight the next paragraph for a mild spoiler;

He likes to shock you so gear up accordingly, and he tends to float above the water in his chamber so you can't hack him to death very easily. He will summon Seekers from Apocrypha as well. I fell back to my trusty bow from the shadows, I still died a few times but eventually took him down. He's a tough cookie, but a level 123 Bosmer should be pretty good with a bow.

 

 

Not sure what the issue is. Took me awhile to figure out what I was supposed to do at the door, but I was fine after that. I think you can just hit anywhere on the door and it will work.

Same as JimBob.  Happened to do it last night as I got through to Crasters, I mean Gratian's journal.

Once I got on to the power attacks, and aimed in the general direction of the "red energy" marks on the outer ring it worked fine.  The top ring attack was a little janky as it was not clear immediately to me that I need to attack it.

The other gotcha was maybe, maybe that the power attacks are "down" "right" "right" "left" but don't quote me.

I see I put the "down" in the wrong order.

On the plus side, the first word of Dragon Aspect makes for a very interesting look for the character.... must have two more words!

I had a problem with this also and after a long time trying to figure it out I had to bring out trusty ol' YouTube to give us a hand.