Stuck waiting for host..

OK, this has been going on since yesterday. Whenever I try and play a game it loads up like normal until I get in a lobby. It searches like it should until what I assume finds a match and then it holds up on waiting for host for a around 30 seconds before searching again. It will go on forever I guess because I leave and try again after about a minute. I've been playing for a month now and I never had this issue.  It's always taken a few seconds to be placed in a match before. I already tried changing my NAT settings to open ( I was strict before with no problems) and it did not work. Idk what to do now.. I've searched for answers, but could not find much. I found a few topics posted by ppl who were experiencing similar problems and that's what made me change my NAT, but like I said it didn't fix it.

I used my 2 day trail from BO2 after my first gold expired , but re-subscribed for another month right after last Friday. Could that be causing the problem? That trial should expire tonight/ early tomorrow morning... Would that even cause this problem, though? I also pissed a few ppl off for not living up to their "skill" expectations. So idk if they reported me for not being a good player ( in my defense I was working on my gold **** shield and I am currently working on unlocking the gold RPG. Both weapons aren't exactly the most novice friendly in this game.) So am I like under investigation? Would that prevent me from playing? Plz any ideas of suggestions will help.

 

Discussion Info


Last updated July 3, 2018 Views 9 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Just wait in the lobby, it should eventually find you a game. If the lobby empties, then maybe try another. This has nothing to do with your account (if you are Gold). AND dont worry about "skill".

Yeah,I've noticed this recently too,It can be a little slow atm.

I am Gold, but I've waited over five minutes in some lobbies and was never placed in a game or let alone with another living soul. Doesn't matter what mode I try both in regular multiplayer and in zombies. I'm forced to wait and wait... This is getting really annoying and like I said before, I would get placed within seconds! Even when the servers were laggy  it never took over  30 seconds to be placed and now I can't even connect with even a single person.  Do you guys know if Xbox has a tech support  line I can call? Because I'm kinda paying for a service I can't use here... >_<

In the search screen go to options, hit the start button for network settings and select "any"

 

   I'm not in front of my consolr so I'm not sure if I gave the exact steps to find it. But maybe that will help.

 

  If you were banned or something of that sort you wouldnt be getting as far as you are.

I'm not sure what causes this, but this happens to me too - & I usually play with a group, so it doesn't just affect you. However, if you wait long enough, it will find you a match. In the meantime, you can do any number of things: get a bite to eat, go to the bathroom, make small talk, or adjust your classes. It'll help keep yourself busy while you wait. ;D

I have had this proble too as of yesterday 1/15/13. I have never had this problem. I can play if i am with a friend but if I search alone it will test games and say waiting for host. This is rather annoying. Other games such as halo 4 work fine, I know its not my internet connection because a friend of mine runs the game on 1.5mg dsl and my connection is much better. I am not banned, as I said I can still play if im in a friends party. Its sad because I just really started to enjoy this game. Hope a fix comes soon.

To what Old Guy said: Hit public games then hit X then choose any, then what ever game mode you were searching for.

  I ran into this myself yesterday, but I wasnt waiting for host most of the time, I believe it was trying to force me as host..

 

  I tried for about an hour off and on, and it didnt really seem to be searching. It would search for a couple seconds, then load the maps for a vote and said we need x more players. Occasionally someone would pop into the lobby and leave.

 

  I tried changing my search settings from best to normal, then to any. I tried at least a half dozen different game modes and kept checking to see if any friends were joinable. I tried rebooting my console.

 

  At one point I did get a "waiting for host" but after a few minutes i backed out, and managed to join up with a couple people on my fl. The one person, anty time I have joined them in the past I have had a decent connection, but this time I played most of the match with a red bar, and sometimes would bounce to 2 bar for a brief moment.

 

  I also noticed, if it has any accuracy to it, the spinning globe on the search screen showed plaenty of people online in my area.

 

   After tha match I just gave up, and when I came back later in the evening it was all normal again.

 

  A temporary issue, but I found it rather annoying at the time. i dont really have time to get on much lately. I finished up work knowing I had a couple hours of the house to myself and expected to take advantage of using the tv without "waiting my turn " ( which means after everyone goes to bed).. I wound up going back to work, and wasnt very happy about it.

It did the waiting thing pretty bad just before the first patch, but I havent noticed it too much since then.

Same problem here, with no change in sight. This is day 5 without anything happening. Soooo, any ideas on what to do differently? Already tried the NAT settings... And nothing. Thoughts?

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.