Stuck, PLEASE Help

After launching the game I get through the intro and after hitting play, I get past the small connecting box that comes up, but then I arrive at the full screen load with the ships in space heading towards titan, like so...

[View:https://pbs.twimg.com/media/Bif4HqiIUAAuWGm.jpg:550:0]

After about 20 minutes it finally says the Connection has timed out. I've rebooted my router, which is not of the Belkin brand, and I continue to stare at the stupid loading circle on the screen above.

Please Help.

 

Discussion Info


Last updated July 4, 2018 Views 1 Applies to:

It may also bear noting that I played the Beta with 0 problems. And I have the game disc, not a download.

Have you tried uninstalling/reinstalling? Might be a problem when Xbox installed from the disc or a problem with the update installing properly. If you try reinstalling - it's probably a good idea to do the reinstall/update without doing anything else on the Xbox. I'd also do a power cycle in between uninstalling and reinstalling.

Was hoping for a less time consuming option, but after manually making sure all appropriate ports are open and still no change, I'm trying it now.

I was installing around 5PM yesterday so the xbox live server issues may be the culprit.

I am having the same problem on the same screen. I got the game and havent been able to play one game online. The beta worked fine for me but for some reason the full game will not let me past this screen. Anybody have any suggestions?  I love this game and will be patient in finding a fix but it is a little frustrating.

ONLY took two days for it to re install.... STILL not working.

I am having the same problem and its driving me crazy. have no idea what to do. reinstalled and still didn't work

It is just that people are overcrowding all the servers. Hopefully ea is at work trying to fix the problem. Believe me I have experienced the same problems.

I have yet to actually play this game because I can't get past this screen... it's getting really frustrating and pissisng me off that I bought this game but can't play it.

I can play classic modes however get stuck in the same manner in the campain mode at the boneyard map. Hope this gets found and fixed quickly. Back to PvZ in the interim.

Update to my previous note, after contacting support at Respawn, was sent to EA which sent me to Microsoft who is handling support for this title, so skip the first two and go direct to MS for support for this title. Uninstalling/re-installing digital version resolved my issue hope this is of value and saves others some possible frustration.