Skyrim not Loading!

Hey folks, I've tried everything to make my skyrim load tha previous saves.

 

I have deleted de the corrupted files, changed the storage devices, cleaned the disc... And i just can't use those savings left. Waht happens is that the main screen appears but at the time you click after choosing "Continue" or "Load", it show the following message "Impossible to read disc".

Cna you guys, please help me out?

 

Thanks a lot!

 

Question Info


Last updated July 4, 2018 Views 22 Applies to:

Greetings Yoa Asakura

I'm sorry that you are having problems while playing your game. Please allow me to help you.

Have you tried to install the disc in your HD? if it's already installed in the HD, please try to delete it and then run the game again.

Also, be sure to check and see if your save file is corrupted or not. If it is, you will need to start a new game save. You can tell if a file is corrupted by going to your hard drive and looking at the Skyrim folder. If there is a little yellow "!" on the save file, it is corrupted. If not, try moving the save to a different storage device like a USB stick and see if that helps.

Finally, please try these steps

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.