Session is Unreachable

Hi there,

I only need 2 more Multiplayer related Achievements, and because the Multiplayer is somewhat dead, you have to boost with friends and all, I have tried that but I seem to have problems with some people which results that once I am in the Lobby, someone else cannot join, and if he is in the Lobby I cannot join... And I get the message "Session is unreachable"... I cannot join random lobbies either, if I happen to find 6 players in the game, I get kicked out and once I try to join via "Join session in Progress" it says Session is Unreachable...

Does anybody know how to fix this ? I have tried all these methods before:

- Turn Port 1000 on (Recommended by Ubisoft, did not help)
- Delete Update and re-update
- Turn router off for 30 seconds

Also, my NAT is Open, I have good connection to LIVE (Although I keep disconnecting from Parties awfully much lately...)

Please, I really need a fix for this, otherwise I will not be able to complete this game, so I say this: Ubisoft, before you make ANY DLC, fix the issue!

Thanks in advance.

 

Discussion Info


Last updated July 3, 2018 Views 2 Applies to:

DLC 3.0 (Da Vinci DLC) has all available modes of MP on it already. So you don't need to switch unless someone in the group doesn't have it.

You may also need an invite to your friend's game session, because I ran into this a LOT. I got an invite from the head guy who started the session.

Oh yeah forgot to mention, DLC is not an issue, I have all the DLC's and when we boost we turn the 2nd DLC pack on for Alliance, so that is not an issue either... It is either my connection or the Servers...