Sega Arcade Games Glitched?!

Okay, I have no idea what's going on here and I would very much appreciate it if someone would help me in resolving this matter.

This happened a while back with Sonic the Hedgehog and I thought nothing of it at the time but now that it has happened again with Golden Axe I'm now coming onto the forums and asking you guys, the Xbox LIVE Community, for help.

 

When I boot up the games they do their usual stuff (showing the Backbone logo) but when it comes to the menu the option "unlock full game" is there. Now, that shouldn't be there seeing as I have unlocked both full games. Hell, I've even got over half of the achievements on Golden Axe. And now I don't know what to do. I have tried downloading both of the full games again, and even the trial versions just to see if that would work but no such luck there.

So what can I do? Because the way I see it is: I'm running out of options.

 

Discussion Info


Last updated October 12, 2018 Views 56 Applies to:

I knew there was an issue with some of the Sega games. I found this on the old forums:

It's a known problem on the Sega titles. At least, the older ones - including Golden Axe. If you don't want to (or can't - maybe you already did it in the past year) transfer the license, you can do the following:

1) Launch the game (using the account which purchased the game).

2) From the in-game menu, choose "unlock full game" (might be slightly different wording).

3) That should bring up a box from the marketplace.

4) It should know that you bought it, and ask if you just want to re-download.

5) Choose "yes".

6) After a few seconds, it should give you a "download complete" - all it did was get a new "key."

7) I think you choose "continue" at that point.  In any case, all you want to do is get out of the blue Marketplace box.  You do NOT want to exit the entire game.

8) Once you're back at the game's menu, it should allow you to play the full game.

The games (I think) ask the binary which console ID to verify - they don't appear to query the marketplace database, to see if that check passes. Unfortunately, you have to do that trick *every time* you want to play.

Unless, of course, you transfer the license to that console. Then the problem is entirely cleared up.

@Smwutches

Thanks mate. I tried that and it worked. But, like you said, I have to do it every time (which sucks) so I'm going to try and go fo the remaining of the achievements in one sitting.

Thanks for the solution for this. Just came across the problem after downloading it again.

i have the same exact issue with my sonic game as well. I'm glad to know that it is an issue and I'm not just crazy. Thank you for this solution. I will give it a try.