Save/Load issues with any worlds

Hoping there is just a simple thing I'm doing wrong here, but I'm currently unable to save/load any game progress correctly. I had a world I worked on for a great many hours. I loaded it up today and spawned in what was the original spawn location in the world. I could not find my buildings, etc. so I assume my changes were not saved.

To test, I started a new world today, made some changes directly around the spawn point, and left a stack of sand in my inventory bar. I tried several combinations of saving and exiting, but my results were that I always spawned in somewhere different, anything in my inventory bar was lost, but world changes seemed to stay.

I'm a little worried to do any real playtime for fear my progress will be lost. Anyone else experiencing this and/or know of a solution?

 

Discussion Info


Last updated July 4, 2018 Views 1 Applies to:

Haven't experienced this myself but have you tried clearing your system cache or re-downloading the game?

I have not. How do you clear the system cache?

Well, I redownloaded and installed the game, but it has not changed anything. I get the same behavior. I did check the Minecraft wiki and it is noted as a bug to be repaired in the MCX360 1.7.3 version.

However, I did test and find that I can place all my stuff into a storage box before saving and it will be there when I return. So, I just need to do that before saving and exiting. Annoying, but at least I know I can play and save stuff in some manner.

That's weird. But aleast ur world loaded tho I had a world with over 100 hours on it and I cant load it so xbox support told me to delete it and just make a new one I was like ughh..

I am having this same problem and it is sooo frustrating

I ave this issue as well and several web sites also report this. Why I gettalked into playing these broken games I never will understand. Wish MS would give me a refund.