San Andreas Update Failiure!!

I've just recently tried to play Grand Theft Auto: San Andreas that I had downloaded from Xbox Marketplace.  When I launch the game, I'm informed that there is a 5Mb update available.  When I go to download and install it, my Xbox just freezes up completely, with the only option being to turn the console off and restart it again.

I've tried clearing the memory cache and deleting/reinstalling the game to see if that would fix the problem, but with no luck so far.  If anyone has any ideas on how to solve this it would be greatly appreciated.

 

Question Info


Last updated July 4, 2018 Views 2 Applies to:

Hey Ian! Can you try to completely delete this game from your HDD, clear the system cache, restart the console, and then try redownloading it from your Download History? Let me know if this helps at all, thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.