Rise of tomb raider achievements not unlocking. HELP

Having a weird issue related to achievements..  ROTR achievements are not unlocking all of sudden plus some achievements with percentage are not showing any progress...Easy and simple achievements like My Next trick shot and No guts and Glory are not unlocking..I have checked guides and completed task required to unlock achievement successfully multiple times but still no luck..

Achievements won't unlock but somehow Compulsive achievement which requires you to complete all challenges was unlocked even when 3 lost city challenges were incomplete according to game..lol. Weird

I tried following things to fix the issue -

Hard reset console

Tried multiple routers..Nat open and network is good according to console

All apps and all working

Deleted that game and installed it again..Same issue.

This new dashboard is causing lot of issue..sometimes my games from library disappears and all..

I hate new dashoard..it's fast but quite buggy...

Please help fixing this issue..is it game related bug or server realted problem

 

Discussion Info


Last updated September 21, 2018 Views 79 Applies to:

Xbox 360 Rise of the Tomb Raider Achievement missing. For my next trick.

I have been having the same problem I have been playing for 5 hours and no achievements have unlocked but they are some that show 100 percent does anyone know what to do

I'm having problems with the No Stone Unturned Achievement not unlocking. I completed the game at 100% and I also received the fancy gold shotgun but I didn't get the achievement, does anyone know what is going on?

yup, same problem here.  Hung Out to Dry not showing as complete, even though all the hanging rabbits are gone.  resetting the cache doesn't help.  

this problem seems to arise when the game gets suspended when the console shuts itself down.  it somehow partially forgets what happened before the shut down.

haven't figured a solution yet.  ALTHOUGH, a problem i was having with collecting coins in the Soviet installation corrected itself when i added the Baba Yaga DLC.  somehow that caused the game to reset/recount the collectibles.