RE5 content add on question

Yesterday I downloaded  the untold stories bundle for this game. Everything works but the mercenaries reunion mode. Each time I try to play it, I get a "can't read disk" error message. I've never had this problem before with the the disk. So, I tried cleaning the disk and re-downloading the content, but the problem still exist. Could it be the download is corrupted or is there something wrong with the disk?

 

Discussion Info


Last updated July 4, 2018 Views 0 Applies to:

I advise you to clear the System Cache by going to System > Press Y on Harddrive > Clear Cache. Restart your console after this, then delete the Add-On you downloaded, in this case 'The Untold Stories'. Redownload the Add-On and try launching again. Disc read errors can be a result of system failure but not always, if you have tried all of the steps I provided to no avail, then call the Xbox hotline at 1-800-4MY-Xbox

Do you by any chance have the Extra Figures content downloaded as well?

-

For some reason the game goes a bit funny with the Bundle and the Extra Figures together.

-

So delete the Extra Figures and the Untold Stories bundle should now work.

What they said haha, i've never had that happen to me though.

I'd just try to re-download it. :)

Thanks everyone. I believe it was the extra figures I downloaded. After I cleared the cache and deleted it, the game started to work.

Glad to hear you got it working.