"We were unable to determine the media usage rights for this content" error Lumia 920

(just in case these forums have some kind of cross-posting rule, I'm summarizing my Microsoft Answers post from here since it seems this is a better place to post it)

Hello!

Today, whenever I try to play one of my songs, I get the "We were unable to determine the media usage rights for this content" error. 

Here's what I've done in the past few days:

  1. Everything was working fine on the music front, but for some reason Xbox Live could never connect
  2. I installed the Portico update
  3. Again, music was working fine, but Xbox Live wasn't
  4. Finally decided to look in the date time settings, and realized that, while my time was right, the date was set to the 28th of January, not the 26th.
  5. Corrected that, then Xbox Live worked perfectly
  6. Xbox Music then gave me a "We're having trouble playing this at the moment. Try again in a little while" error (different than the media usage rights error) for all of my Music Pass downloaded music.
  7. If I changed my date back to the 28th it works, but then Xbox Live didn't work (and it's the wrong date, which messes with my camera and stuff)
  8. Waited a day to see if passing midnight might fix it for some reason, but it didn't, so confirmed that it's 2 days off
  9. While messing around a bit, I noticed that 2012 is 2 days off from 2013, so maybe that's the problem?
  10.  A lot of messing around later (like disassociating it from my xbox live account, downloading songs, soft resets, etc) it stopped giving me the "We're having trouble playing this at the moment" error and started giving me the "We are unable to confirm media usage rights for this content error" unless I changed the date to 2 days in the future

  11. After even more messing around (like taking it offline, messing around with the dates, etc.) I managed to make it worse -  no songs downloaded to my phone will play, no matter what my date settings are. I just keep getting the "we are unable to determine media usage rights for this content," but I can still stream songs.

I've tried doing soft resets and then correcting the time problems (didn't help), playing music from my Xbox cloud collection and seeing if that fixes it some how (it didn't, but I could play songs from my cloud collection), changing the year in date time (which didn't help), and downloading a song from the marketplace (which I couldn't play). I'm using a Lumia 920 running Xbox Music, Vodaphone branded running on AT&T, recently updated to Portico.

Thanks for your help,

Matthew

 

Question Info


Last updated July 4, 2018 Views 2 Applies to:

Have you tried the suggestions here? support.microsoft.com/.../2792058

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes, unfortuanantly none of the suggestions helped.

Thanks,

Matthew

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey MatthewThePC,
 

So, even after you deleted the songs then re-downloaded them you are still getting the DRM message?  Just to verify, you are using your Windows Phone on your personal Wi-Fi connection at home?
 

If none of those steps worked from the helpful post that eco shared above, did you try the websites that support page mentioned to check if they didn't work?
 

Let us know.  Thanks.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.