"Infinite Loading Screen", cannot connect to servers, still cannot play Titanfall

I have been able to play Titanfall twice in the past week.  Once the Start screen loads and the game chooses the best server, the PLAY option appears, and then the splash screen "Attempting to connect ..." appears.  Then the splash screen with the ships and rotating wheel appears.  The game is locked on that screen for ~10 mins before the error "connection to server was lost" appears.

Seems by now the Titanfall connection issues should be addressed, but some (including myself) still have difficulty connecting to a game.  I have tried everything I could find on the internet to rectify the issue, including the various "fixes" listed on the official MS and Titanfall sites.  After spending an hour with EA support, they told me that the reason for the "infinite loading screen" problem is the Microsoft servers.

Although I do not have a robust internet connection, I can play multiplayer CoD:Ghosts on the Xbox One with no problems whatsoever.

What gives, Microsoft?

 

Discussion Info


Last updated July 4, 2018 Views 18 Applies to:

getting a similar problem, the timer counts down to start the game then it loads for 10mins and 'cannot connect to servers' iv tried everything restarting, reinstalling and i even took the game back for another. i have 38mb wired connection. the game is going back for a refund, junk.

here is what i did to fix the problem for good. i took titanfall back to the store and exchanged it for another game i can play. and i have been playing the different game just fine. i would just take it back to the store and be done with it. i am sorry but if a game company is gonna make an online only game, the one thing they need to make sure their game does is connect online. i decided i am not dealing with that garbage. it's been 10 days since release and people still have this problem? epic fail i say.

restart system

This worked for me and 3 of my friends, and I haven't had a problem since,  go the website help.ea.com It gives you a workaround by telling you how to manually set up your DNS, its super simple and only takes a few minutes, hope this helps you