"A Continual Feast" mission glitch?

I tried for 1/2 hour last night and 1/2 hour tonight trying to do this mission with no luck (it's the one where you have to break some horses with your Uncle).  The first two horses are easy, but is there a glitch that prevents the third horse from breaking?  I've tried restarting the mission and trying different breeds, but nothing seems to work.

 

Discussion Info


Last updated July 4, 2018 Views 5 Applies to:

I've had this exact same issue.  First two horses are no problem, but 30+ minutes of trying to break that third horse has led to failure after failure.  Infuriating since breaking a horse in RDR isn't exactly rocket science.

I have finished the game twice. Could you explain a little bit more?

Well how come every time I lasso a horse is falls over dead?

i dont understand why many of you have had issues with this mission, i never had a problem and i have beaten the game numerous times on many different accounts, the only suggestion i can give is keep trying and concentrate a little more on what your doing, if you go into something frustrated and upset you wont be thinking clearly and fail every time, just stay calm and remember....its only a game.