Purple cloud screen- kind of frozen

possible *Spoilers*

I was on the Chesty quest in Sunset house. It was only the third move into the Chess game when the game sort of froze. I couldn't move my knight into any spaces. The knight was lit up. Al the characters were still moving, I could move the circular target around, but the game wasn't responding to any of the A button commands. So I just "save and continue"-ed the game. Then I just exited to the home screen. When I logged back into the game it just showed me a purple-ish screen with floating clouds. I can hear birds chirping. Numerous times I've restarted my console and I always end up with the same screen. I can press and hold the B button and it makes the sound that my magic is charging and releasing. The screen will just turn bright white and slowly return back to the purple with clouds. One time I was able to go to the sanctuary and I tried to go to other places, but it just told me that I couldn't go anywhere until I finished my quest. I've also tried clearing the cache on my xbox 360 and not installing some of the updates via xbox live, but to the same results.

any way I can save my progress, I'm not a big fan of starting all over again.

 

Discussion Info


Last updated July 3, 2018 Views 0 Applies to: